5412 C++ Programming Manual: C:/C++ Directory Reference

5412 C++ Programming Manual
  • Main Page
  • Classes
  • Files

C++ Directory Reference

Files

         JY5412Core.h
JYDAQError.h
Generated by doxygen 1.15.0


5412 C++ Programming Manual: C:/C++/JY5412Core.h File Reference

  • File List
  • File Members
  • C:
  • C++
Classes | Macros | Typedefs | Enumerations | Functions
JY5412Core.h File Reference
#include <stdio.h>

Classes

struct ChangeDetectionEventInfo

Macros

#define | JY5412_NumOfPort 4
Windows.
#define | JY5412_NumOfLinesPerPort 24
#define | NumberOfLines 96

Typedefs

typedef void * | JY5412_DeviceHandle
typedef void * | JY5412_TaskHandle
typedef void(* | JY5412_CallbackFunc) (JY5412_DeviceHandle hDevice, ChangeDetectionEventInfo *eventInfo, void *callbackData)

Enumerations

enum | JY5412_DIO_Direction { Output = 0x0 , Input = 0x1 }
enum | JY5412_DI_Terminal { Floating = 0x0 , PullUp = 0x1 , PullDown = 0x2 }
enum | JY5412_DO_Terminal { PushPull = 0x0 , OpenDrain = 0x1 }
enum | JY5412_DO_ExpirationState { High = 0x0 , Low = 0x1 , Tristate = 0x2 , NoChange =0x3 }
enum | JY5412_ChangeDetectionMode { RisingEdge = 0x1 , FallingEdge = 0x2 , BothEdge = 0x0 }
enum | JY5412_LogicLevel { CMOS3V3 = 0x0 , CMOS5V0 = 0x1 }
enum | JY5412_Event { ChangeDetectionEvent }
enum | JY5412_ChangeDetectionSource { LinesCOS = 0x0 , Timer = 0x1 , EventCounter =0x2 , LineXOrnLineY = 0x3 }

Functions

JY5412API int | JY5412_Open (int slotNumber, JY5412_DeviceHandle *hDevice)
Open the JY5412 board using the slot number or the board serial number.
JY5412API int | JY5412_OpenByName (const char *cardName, JY5412_DeviceHandle *hDevice)
Open this JY5412 board using the board alias name which is set by JYTEK utility JYDM.
JY5412API int | JY5412_Close (JY5412_DeviceHandle hDevice)
JY5412API int | JY5412_SetDeviceStatusLed (JY5412_DeviceHandle hDevice, bool enable, unsigned int frequency)
JY5412API int | JY5412_SetLogicLevel (JY5412_DeviceHandle hDevice, int port, JY5412_LogicLevel logicLevel)
Set the logic level.
JY5412API int | JY5412_SetOutputPowerUpStates (JY5412_DeviceHandle hDevice, const int *port, const int *line, const JY5412_DO_Terminal *outputMode, const bool *values, int numOfLines)
Set the default output power-on state.
JY5412API int | JY5412_GetOutputPowerUpStates (JY5412_DeviceHandle hDevice, const int *port, const int *line, JY5412_DO_Terminal *outputMode, bool *values, int numOfLines)
Obtain the default output power-on state.
JY5412API int | JY5412_SetInputPowerUpStates (JY5412_DeviceHandle hDevice, const int *port, const int *line, const JY5412_DI_Terminal *inputMode, int numOfLines)
Set the default input power-on state.
JY5412API int | JY5412_GetInputPowerUpStates (JY5412_DeviceHandle hDevice, const int *port, const int *line, JY5412_DI_Terminal *inputMode, int numOfLines)
Obtain the default input power-on state.
JY5412API int | JY5412_SetLogicLevelPowerUpStates (JY5412_DeviceHandle hDevice, const int *port, const JY5412_LogicLevel *logicLevels, int numberOfPorts)
设置默认的上电状态的逻辑电位
JY5412API int | JY5412_GetLogicLevelPowerUpStates (JY5412_DeviceHandle hDevice, const int *port, JY5412_LogicLevel *logicLevels, int numberOfPorts)
Set the logical voltage for the default power-on state.
JY5412API int | JY5412_CommitPowerUpStates (JY5412_DeviceHandle hDevice)
Submit power-on status configuration.
JY5412API int | JY5412_GetPowerUpStates (JY5412_DeviceHandle hDevice, const int *port, const int *line, JY5412_DIO_Direction *direction, JY5412_DI_Terminal *inputMode, JY5412_DO_Terminal *outputMode, bool *values, int numOfLines)
Obtain the power-on configuration.
JY5412API int | JY5412_ConfigInput (JY5412_DeviceHandle hDevice, const int *port, const int *line, const JY5412_DI_Terminal *inputMode, int numOfLines)
Set the input mode and configure it as an input pin.
JY5412API int | JY5412_ConfigOutput (JY5412_DeviceHandle hDevice, const int *port, const int *line, const JY5412_DO_Terminal *outputMode, int numOfLines)
Set the output mode and configure it to output the pin.
JY5412API int | JY5412_WriteDigitalLines (JY5412_DeviceHandle hDevice, const int *port, const int *line, const bool *valuesToWrite, int numOfLines)
Set the output through a group of port numbers and line numbers.
JY5412API int | JY5412_ReadDigitalLines (JY5412_DeviceHandle hDevice, const int *port, const int *line, bool *valuesRead, int numOfLines)
DI reads a single point using the port number and a set of line numbers.
JY5412API int | JY5412_CommitDIOConfiguration (JY5412_DeviceHandle hDevice)
Submit DIO configuration.
JY5412API int | JY5412_DebounceFilter_Enable (JY5412_DeviceHandle hDevice, int port, const int *line, int numOfLines, bool enable)
Set whether digital filtering is enabled for the specified line.
JY5412API int | JY5412_DebounceFilter_SetMinPulseWidth (JY5412_DeviceHandle hDevice, int port, int minPulseWidth)
Set the filtering parameters for the specified line.
JY5412API int | JY5412_Watchdog_Config (JY5412_DeviceHandle hDevice, bool enable, double timeout, const int *port, const int *line, const JY5412_DO_ExpirationState *expState, int lineCount)
Configure the watchdog task.
JY5412API int | JY5412_Watchdog_ResetTimer (JY5412_DeviceHandle hDevice)
Reset the watchdog task.
JY5412API int | JY5412_Watchdog_CheckIfExpired (JY5412_DeviceHandle hDevice, bool *hasExpired)
Check if the watchdog has expired.
JY5412API int | JY5412_Watchdog_ClearExpiration (JY5412_DeviceHandle hDevice)
Clear the lock status of the timeout watchdog task.
JY5412API int | JY5412_Watchdog_SetTimeout (JY5412_DeviceHandle hDevice, double timeout)
Configure the timeout period of the watchdog.
JY5412API int | JY5412_Watchdog_GetTimeout (JY5412_DeviceHandle hDevice, double *timeout)
Obtain the timeout period of the watchdog.
JY5412API int | JY5412_Watchdog_SetExpirationState (JY5412_DeviceHandle hDevice, const int *port, const int *line, const JY5412_DO_ExpirationState *expState, int lineCount)
Configure the timeout state of the watchdog.
JY5412API int | JY5412_Watchdog_GetExpirationState (JY5412_DeviceHandle hDevice, const int *port, const int *line, JY5412_DO_ExpirationState *expState, int lineCount)
Obtain the timeout status of the watchdog.
JY5412API int | JY5412_Watchdog_Start (JY5412_DeviceHandle hDevice)
Start the watchdog task.
JY5412API int | JY5412_Watchdog_Stop (JY5412_DeviceHandle hDevice)
Stop the watchdog task.
JY5412API void | JY5412_ChangeDetection_RegisterEventHandler (JY5412_DeviceHandle hDevice, int option, JY5412_CallbackFunc callback, void *callbackData)
Register for change detection events (only one callback is allowed).
JY5412API int | JY5412_ChangeDetection_Config (JY5412_DeviceHandle hDevice, const int *port, const int *line, const JY5412_ChangeDetectionMode *mode, int lineCount)
Configuration change detection parameters.
JY5412API int | JY5412_ChangeDetection_Enable (JY5412_DeviceHandle hDevice, bool enable)
Enable / Disable Change Detection.
void | JY5412_ChangeDetection_SendEvent (JY5412_DeviceHandle hDevice)
Trigger the change detection event.

Macro Definition Documentation

◆ JY5412_NumOfLinesPerPort

#define JY5412_NumOfLinesPerPort 24

◆ JY5412_NumOfPort

#define JY5412_NumOfPort 4

Windows.

Linux

◆ NumberOfLines

#define NumberOfLines 96

Typedef Documentation

◆ JY5412_CallbackFunc

typedef void(* JY5412_CallbackFunc) (JY5412_DeviceHandle hDevice, ChangeDetectionEventInfo *eventInfo, void *callbackData)

◆ JY5412_DeviceHandle

typedef void* JY5412_DeviceHandle

◆ JY5412_TaskHandle

typedef void* JY5412_TaskHandle

Enumeration Type Documentation

◆ JY5412_ChangeDetectionMode

enum JY5412_ChangeDetectionMode
Enumerator
RisingEdge
FallingEdge
BothEdge

◆ JY5412_ChangeDetectionSource

enum JY5412_ChangeDetectionSource
Enumerator
LinesCOS
Timer
EventCounter
LineXOrnLineY

◆ JY5412_DI_Terminal

enum JY5412_DI_Terminal
Enumerator
Floating
PullUp
PullDown

◆ JY5412_DIO_Direction

enum JY5412_DIO_Direction
Enumerator
Output
Input

◆ JY5412_DO_ExpirationState

enum JY5412_DO_ExpirationState
Enumerator
High
Low
Tristate
NoChange

◆ JY5412_DO_Terminal

enum JY5412_DO_Terminal
Enumerator
PushPull
OpenDrain

◆ JY5412_Event

enum JY5412_Event
Enumerator
ChangeDetectionEvent

◆ JY5412_LogicLevel

enum JY5412_LogicLevel
Enumerator
CMOS3V3
CMOS5V0

Function Documentation

◆ JY5412_ChangeDetection_Config()

JY5412API int JY5412_ChangeDetection_Config | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | const JY5412_ChangeDetectionMode * | mode,
 |  | int | lineCount )

Configuration change detection parameters.

Parameters
hDevice | Device handle
port | Port number
line | Array of lines to be detected
mode | Array of change detection modes corresponding to the lines
lineCount | Array length
Returns
0 if Success or other error code

◆ JY5412_ChangeDetection_Enable()

JY5412API int JY5412_ChangeDetection_Enable | ( | JY5412_DeviceHandle | hDevice,
 |  | bool | enable )

Enable / Disable Change Detection.

Parameters
hDevice | Device handle
enable | Whether to enable change detection

◆ JY5412_ChangeDetection_RegisterEventHandler()

JY5412API void JY5412_ChangeDetection_RegisterEventHandler | ( | JY5412_DeviceHandle | hDevice,
 |  | int | option,
 |  | JY5412_CallbackFunc | callback,
 |  | void * | callbackData )

Register for change detection events (only one callback is allowed).

Parameters
hDevice | Device handle
option | Used to specify whether the user code called by the callback function is executed synchronously or asynchronously. Synchronous execution is currently supported first
callback | Callback function
callbackData | User data
Returns
0 if Success or other error code

◆ JY5412_ChangeDetection_SendEvent()

void JY5412_ChangeDetection_SendEvent ( JY5412_DeviceHandle hDevice )

Trigger the change detection event.

Parameters
hDevice | Device handle
event | Event type
Returns
0 if Success or other error code

◆ JY5412_Close()

JY5412API int JY5412_Close ( JY5412_DeviceHandle hDevice )
Parameters
hDevice
Returns

◆ JY5412_CommitDIOConfiguration()

JY5412API int JY5412_CommitDIOConfiguration ( JY5412_DeviceHandle hDevice )

Submit DIO configuration.

Parameters
hDevice Device handle
Returns
0: Success, otherwise: Failure

◆ JY5412_CommitPowerUpStates()

JY5412API int JY5412_CommitPowerUpStates ( JY5412_DeviceHandle hDevice )

Submit power-on status configuration.

Parameters
hDevice Device handle
Returns
0: Success, otherwise: Failure

◆ JY5412_ConfigInput()

JY5412API int JY5412_ConfigInput | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | const JY5412_DI_Terminal * | inputMode,
 |  | int | numOfLines )

Set the input mode and configure it as an input pin.

Parameters
hDevice | Device handle
port | Port number
line | Pin number
inputMode | Input mode
numOfLines | Number of elements in the channel array
Returns
0: Success, otherwise: Failure

◆ JY5412_ConfigOutput()

JY5412API int JY5412_ConfigOutput | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | const JY5412_DO_Terminal * | outputMode,
 |  | int | numOfLines )

Set the output mode and configure it to output the pin.

Parameters
hDevice | Device handle
port | Port number
line | Pin number
outputMode | Output mode
numOfLines | Number of elements in the channel array
Returns
0: Success, otherwise: Failure

◆ JY5412_DebounceFilter_Enable()

JY5412API int JY5412_DebounceFilter_Enable | ( | JY5412_DeviceHandle | hDevice,
 |  | int | port,
 |  | const int * | line,
 |  | int | numOfLines,
 |  | bool | enable )

Set whether digital filtering is enabled for the specified line.

Each line can be independently enabled.

Parameters
hDevice | Device handle
port | Port number
lines | Enabled/Disabled lines
numOfLines | Number of lines
enable | Enable/Disable

///

Returns
0 if success or other error code

◆ JY5412_DebounceFilter_SetMinPulseWidth()

JY5412API int JY5412_DebounceFilter_SetMinPulseWidth | ( | JY5412_DeviceHandle | hDevice,
 |  | int | port,
 |  | int | minPulseWidth )

Set the filtering parameters for the specified line.

The minPulseWidth parameter is shared by each port.

Parameters
hDevice | Device handle
port | Port number
minPulseWidth | Pulses with a width less than this value will be filtered out. Unit: ns
Returns
0 if success or other error code

◆ JY5412_GetInputPowerUpStates()

JY5412API int JY5412_GetInputPowerUpStates | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | JY5412_DI_Terminal * | inputMode,
 |  | int | numOfLines )

Obtain the default input power-on state.

Parameters
hDevice | Device handle
port | Port number
line | Pin number
inputMode | Input mode
numOfLines | Number of elements in the channel array
Returns
0: Success, otherwise: Failure

◆ JY5412_GetLogicLevelPowerUpStates()

JY5412API int JY5412_GetLogicLevelPowerUpStates | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | JY5412_LogicLevel * | logicLevels,
 |  | int | numberOfPorts )

Set the logical voltage for the default power-on state.

Parameters
hDevice | Device handle
port | Port number
logicLevels | Logic levels
numberOfPorts | Number of elements in the port array
Returns
0: Success, otherwise: Failure

◆ JY5412_GetOutputPowerUpStates()

JY5412API int JY5412_GetOutputPowerUpStates | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | JY5412_DO_Terminal * | outputMode,
 |  | bool * | values,
 |  | int | numOfLines )

Obtain the default output power-on state.

Parameters
hDevice | Device handle
port | Port number
line | Pin number
outputMode | Output mode
values | Output values
numOfLines | Number of elements in the channel array
Returns
0: Success, otherwise: Failure

◆ JY5412_GetPowerUpStates()

JY5412API int JY5412_GetPowerUpStates | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | JY5412_DIO_Direction * | direction,
 |  | JY5412_DI_Terminal * | inputMode,
 |  | JY5412_DO_Terminal * | outputMode,
 |  | bool * | values,
 |  | int | numOfLines )

Obtain the power-on configuration.

Parameters
hDevice | Device handle
port | Port number
line | Pin number
direction | Corresponding pin direction, Input/Output
inputMode | Input mode
outputMode | Output mode
values | Output values
numOfLines | Number of elements in the channel array
Returns
0: Success, otherwise: Failure

◆ JY5412_Open()

JY5412API int JY5412_Open | ( | int | slotNumber,
 |  | JY5412_DeviceHandle * | hDevice )

Open the JY5412 board using the slot number or the board serial number.

PXIe slot number is defined by the DIP switch. The board number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if Success or other error code

◆ JY5412_OpenByName()

JY5412API int JY5412_OpenByName | ( | const char * | cardName,
 |  | JY5412_DeviceHandle * | hDevice )

Open this JY5412 board using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if Success or other error code

◆ JY5412_ReadDigitalLines()

JY5412API int JY5412_ReadDigitalLines | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | bool * | valuesRead,
 |  | int | numOfLines )

DI reads a single point using the port number and a set of line numbers.

Parameters
hDevice | Device handle
port | Port number
lineID | Line array
readValues | Read the values of the specified port and line
Returns
0: Success, otherwise: Failure

◆ JY5412_SetDeviceStatusLed()

JY5412API int JY5412_SetDeviceStatusLed | ( | JY5412_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

◆ JY5412_SetInputPowerUpStates()

JY5412API int JY5412_SetInputPowerUpStates | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | const JY5412_DI_Terminal * | inputMode,
 |  | int | numOfLines )

Set the default input power-on state.

Parameters
hDevice | Device handle
port | Port number
line | Pin number
inputMode | Input mode
numOfLines | Number of elements in the channel array
Returns
0: Success, otherwise: Failure

◆ JY5412_SetLogicLevel()

JY5412API int JY5412_SetLogicLevel | ( | JY5412_DeviceHandle | hDevice,
 |  | int | port,
 |  | JY5412_LogicLevel | logicLevel )

Set the logic level.

Each port can be configured independently.

Parameters
hDevice | Device handle
port | Port number, 0-3
logicLevel | Logic level, COMS 3.3/5V options available
Returns
0: Success, otherwise: Failure

◆ JY5412_SetLogicLevelPowerUpStates()

JY5412API int JY5412_SetLogicLevelPowerUpStates | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const JY5412_LogicLevel * | logicLevels,
 |  | int | numberOfPorts )

设置默认的上电状态的逻辑电位

Parameters
hDevice | 设备句柄
port | 端口号
logicLevels | 逻辑电位
numberOfPorts | 端口数组元素个数
Returns
0:成功, 其他:失败

◆ JY5412_SetOutputPowerUpStates()

JY5412API int JY5412_SetOutputPowerUpStates | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | const JY5412_DO_Terminal * | outputMode,
 |  | const bool * | values,
 |  | int | numOfLines )

Set the default output power-on state.

Parameters
hDevice | Device handle
port | Port number
line | Pin number
outputMode | Output mode
values | Output values
numOfLines | Number of elements in the channel array
Returns
0: Success, otherwise: Failure

◆ JY5412_Watchdog_CheckIfExpired()

JY5412API int JY5412_Watchdog_CheckIfExpired | ( | JY5412_DeviceHandle | hDevice,
 |  | bool * | hasExpired )

Check if the watchdog has expired.

Parameters
hDevice | Device handle
hasExpired | Whether it has expired
Returns
0 if success or other error code

◆ JY5412_Watchdog_ClearExpiration()

JY5412API int JY5412_Watchdog_ClearExpiration ( JY5412_DeviceHandle hDevice )

Clear the lock status of the timeout watchdog task.

Parameters
hDevice Device handle
Returns
0 if success or other error code

◆ JY5412_Watchdog_Config()

JY5412API int JY5412_Watchdog_Config | ( | JY5412_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | double | timeout,
 |  | const int * | port,
 |  | const int * | line,
 |  | const JY5412_DO_ExpirationState * | expState,
 |  | int | lineCount )

Configure the watchdog task.

Parameters
hDevice | Device handle
enable | Whether to enable the watchdog
timeout | Timeout duration, in seconds
port | Port number
lineID | Array of lines to be monitored
expState | Array of expiration states corresponding to the line array
lineCount | Array length
Returns
0 if success or other error code

◆ JY5412_Watchdog_GetExpirationState()

JY5412API int JY5412_Watchdog_GetExpirationState | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | JY5412_DO_ExpirationState * | expState,
 |  | int | lineCount )

Obtain the timeout status of the watchdog.

Parameters
hDevice | Device handle
port | Port number
line | Array of lines to be monitored
expState | Array of expiration states corresponding to the lines
lineCount | Array length
Returns
0 if success or other error code

◆ JY5412_Watchdog_GetTimeout()

JY5412API int JY5412_Watchdog_GetTimeout | ( | JY5412_DeviceHandle | hDevice,
 |  | double * | timeout )

Obtain the timeout period of the watchdog.

Parameters
hDevice | Device handle
timeout | Timeout duration, in seconds
Returns
0 if success or other error code

◆ JY5412_Watchdog_ResetTimer()

JY5412API int JY5412_Watchdog_ResetTimer ( JY5412_DeviceHandle hDevice )

Reset the watchdog task.

Parameters
hDevice Device handle
Returns
0 if success or other error code

◆ JY5412_Watchdog_SetExpirationState()

JY5412API int JY5412_Watchdog_SetExpirationState | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | const JY5412_DO_ExpirationState * | expState,
 |  | int | lineCount )

Configure the timeout state of the watchdog.

This requires configuring all the lines that were previously configured.

Parameters
hDevice | Device handle
port | Port number
line | Array of lines to be monitored
expState | Array of expiration states corresponding to the lines
lineCount | Array length
Returns
0 if success or other error code

◆ JY5412_Watchdog_SetTimeout()

JY5412API int JY5412_Watchdog_SetTimeout | ( | JY5412_DeviceHandle | hDevice,
 |  | double | timeout )

Configure the timeout period of the watchdog.

Parameters
hDevice | Device handle
timeout | Timeout duration, in seconds
Returns
0 if success or other error code

◆ JY5412_Watchdog_Start()

JY5412API int JY5412_Watchdog_Start ( JY5412_DeviceHandle hDevice )

Start the watchdog task.

Parameters
hDevice Device handle
Returns

◆ JY5412_Watchdog_Stop()

JY5412API int JY5412_Watchdog_Stop ( JY5412_DeviceHandle hDevice )

Stop the watchdog task.

Parameters
hDevice Device handle
Returns

◆ JY5412_WriteDigitalLines()

JY5412API int JY5412_WriteDigitalLines | ( | JY5412_DeviceHandle | hDevice,
 |  | const int * | port,
 |  | const int * | line,
 |  | const bool * | valuesToWrite,
 |  | int | numOfLines )

Set the output through a group of port numbers and line numbers.

Parameters
hDevice | Device handle
port | Port number, 0-3. The array length is numOfLines. Port and line are one-to-one corresponding
line | Line number, 0-23. The array length is numOfLines
writeValues | Set the values of the specified port and line
numOfLines | Number of elements in the DO channel array

///

Returns
0 if success or other error code


5412 C++ Programming Manual: ChangeDetectionEventInfo Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
ChangeDetectionEventInfo Struct Reference

#include <JY5412Core.h>

Public Attributes

bool | lineChanged [NumberOfLines]
int | lineLevel [NumberOfLines]

Member Data Documentation

◆ lineChanged

bool ChangeDetectionEventInfo::lineChanged[NumberOfLines]

◆ lineLevel

int ChangeDetectionEventInfo::lineLevel[NumberOfLines]
The documentation for this struct was generated from the following file:
  • C:/C++/JY5412Core.h


5412 C++ Programming Manual: C:/C++/JYDAQError.h File Reference

  • C:
  • C++
Macros
JYDAQError.h File Reference

Macros

#define | Success (0)
#define | ErrorCodeOffset (-10000)
#define | Error_OpenDeviceFailed (ErrorCodeOffset - 1)
#define | Error_CloseDeviceFailed (ErrorCodeOffset - 2)
#define | Error_ResetDeviceFailed (ErrorCodeOffset - 3)
#define | Error_InitalDeviceFailed (ErrorCodeOffset - 4)
#define | Error_ActiveDeviceFailed (ErrorCodeOffset - 5)
#define | Error_DeviceSlotNumberInvalid (ErrorCodeOffset - 6)
#define | Error_DeviceNumberInvalid (ErrorCodeOffset - 7)
#define | Error_DeviceNameInvalid (ErrorCodeOffset - 8)
#define | Error_DeviceHandleInvalid (ErrorCodeOffset - 9)
#define | Error_InitalEEPROMFailed (ErrorCodeOffset - 10)
#define | Error_ReadEEPROMFailed (ErrorCodeOffset - 11)
#define | Error_WriteEEPROMFailed (ErrorCodeOffset - 12)
#define | Error_TimeBaseSourceInvalid (ErrorCodeOffset - 13)
#define | Error_CLKMuxSelectFailed (ErrorCodeOffset - 14)
#define | Error_PLLSetFailed (ErrorCodeOffset - 15)
#define | Error_PLLLockFailed (ErrorCodeOffset - 16)
#define | Error_PLLCrashed (ErrorCodeOffset - 17)
#define | Error_PLLOutputFreqOutOfRange (ErrorCodeOffset - 18)
#define | Error_GetDeviceAttributeFailed (ErrorCodeOffset - 19)
#define | Error_SetDeviceAttributeFailed (ErrorCodeOffset - 20)
#define | Error_GetDeviceCalibrationDataFailed (ErrorCodeOffset - 21)
#define | Error_MallocMemoryFailed (ErrorCodeOffset - 22)
#define | Error_UnSupportOperation (ErrorCodeOffset - 23)
#define | Error_ReleaseDeviceResourceFailed (ErrorCodeOffset - 24)
#define | Error_ParamInvalid (ErrorCodeOffset - 25)
#define | Error_DevicePropertyInvalid (ErrorCodeOffset - 26)
#define | Error_FirmwareVersionNotMatch (ErrorCodeOffset - 27)
#define | Error_DeviceCalibrationCRCVerifyFailed (ErrorCodeOffset - 28)
#define | Error_DeviceCalibrationDataInvalid (ErrorCodeOffset - 29)
#define | ErrorCodeOffset_AI (-10100)
#define | Error_AI_ChannelNumberInvalid (ErrorCodeOffset_AI - 1)
#define | Error_AI_ChannelCountInvalid (ErrorCodeOffset_AI - 2)
#define | Error_AI_ChannelCountOverRang (ErrorCodeOffset_AI - 3)
#define | Error_AI_ChannelIndexOverRange (ErrorCodeOffset_AI - 4)
#define | Error_AI_VoltageRangInvalid (ErrorCodeOffset_AI - 5)
#define | Error_AI_CurrentRangeInvalid (ErrorCodeOffset_AI - 6)
#define | Error_AI_ResistanceRangeInvalid (ErrorCodeOffset_AI - 7)
#define | Error_AI_RTDTopologyTypeInvalid (ErrorCodeOffset_AI - 8)
#define | Error_AI_TerminalInvalid (ErrorCodeOffset_AI - 9)
#define | Error_AI_CoupingInvalid (ErrorCodeOffset_AI - 10)
#define | Error_AI_TimeBaseSourceInvalid (ErrorCodeOffset_AI - 11)
#define | Error_AI_SampleClockSourceInvalid (ErrorCodeOffset_AI - 12)
#define | Error_AI_SampleRateInvalid (ErrorCodeOffset_AI - 13)
#define | Error_AI_ConvertClockSourceInvalid (ErrorCodeOffset_AI - 14)
#define | Error_AI_ConvertRateInvalid (ErrorCodeOffset_AI - 15)
#define | Error_AI_UnSupportSampleMode (ErrorCodeOffset_AI - 16)
#define | Error_AI_SamplesToAcquireInvalid (ErrorCodeOffset_AI - 17)
#define | Error_AI_SamplesToAcquireOverRange (ErrorCodeOffset_AI - 18)
#define | Error_AI_SamplesToAcquireNotLessPreTriggerSamples (ErrorCodeOffset_AI - 19)
#define | Error_AI_SampleModeAndTriggerModeNotMatch (ErrorCodeOffset_AI - 20)
#define | Error_AI_PreTriggerSamplesInvalid (ErrorCodeOffset_AI - 21)
#define | Error_AI_ReTriggerCountInvalid (ErrorCodeOffset_AI - 22)
#define | Error_AI_TriggerDelayInvalid (ErrorCodeOffset_AI - 23)
#define | Error_AI_TriggerTypeInvalid (ErrorCodeOffset_AI - 24)
#define | Error_AI_TriggerModeInvalid (ErrorCodeOffset_AI - 25)
#define | Error_AI_DigitalTriggerSourceInvalid (ErrorCodeOffset_AI - 26)
#define | Error_AI_AnalogTriggerSourceInvalid (ErrorCodeOffset_AI - 27)
#define | Error_AI_AnalogTriggerThresholdInvalid (ErrorCodeOffset_AI - 28)
#define | Error_AI_BufferSizeInvalid (ErrorCodeOffset_AI - 29)
#define | Error_AI_DiagnoseFailed (ErrorCodeOffset_AI - 30)
#define | Error_AI_TLastNotAligned (ErrorCodeOffset_AI - 31)
#define | Error_AI_TriggerStateNotMatch (ErrorCodeOffset_AI - 32)
#define | Error_AI_NotStart (ErrorCodeOffset_AI - 33)
#define | Error_AI_ReadDataTimeOut (ErrorCodeOffset_AI - 34)
#define | Error_AI_BufferPointerIsNull (ErrorCodeOffset_AI - 35)
#define | Error_AI_DataAddressIsNull (ErrorCodeOffset_AI - 36)
#define | Error_AI_BufferOverflow (ErrorCodeOffset_AI - 37)
#define | Error_AI_TimeOut (ErrorCodeOffset_AI - 38)
#define | Error_AI_AnalogTriggerThresholdOverRange (ErrorCodeOffset_AI - 39)
#define | Error_AI_AnalogTriggerNoSupportStartTriggerMode (ErrorCodeOffset_AI - 40)
#define | Error_AI_PreTriggerSamplesMustBeGreaterThanZero (ErrorCodeOffset_AI - 41)
#define | Error_AI_DSModeSampleRateInvalid (ErrorCodeOffset_AI - 42)
#define | Error_AI_ExternalSampleRateOverRange (ErrorCodeOffset_AI - 43)
#define | Error_AI_Inter_ADCInitFailed (ErrorCodeOffset_AI - 50)
#define | Error_AI_Inter_ADCSetChannelFailed (ErrorCodeOffset_AI - 51)
#define | Error_AI_Inter_ADCSetSampleRateFailed (ErrorCodeOffset_AI - 52)
#define | Error_AI_Inter_ADCEnableAdjustFailed (ErrorCodeOffset_AI - 53)
#define | Error_AI_Inter_ADCSetAdjustDataFailed (ErrorCodeOffset_AI - 54)
#define | Error_AI_Inter_ADCStartFailed (ErrorCodeOffset_AI - 55)
#define | Error_AI_Inter_ADCStoptFailed (ErrorCodeOffset_AI - 56)
#define | Error_AI_Inter_RXInitFailed (ErrorCodeOffset_AI - 57)
#define | ErrorCodeOffset_AO (-10200)
#define | Error_AO_ChannelNumberInvalid (ErrorCodeOffset_AO - 1)
#define | Error_AO_ChannelCountInvalid (ErrorCodeOffset_AO - 2)
#define | Error_AO_ChannelCountOverRang (ErrorCodeOffset_AO - 3)
#define | Error_AO_ChannelIndexOverRange (ErrorCodeOffset_AO - 4)
#define | Error_AO_VoltageRangInvalid (ErrorCodeOffset_AO - 5)
#define | Error_AO_CurrentRangeInvalid (ErrorCodeOffset_AO - 6)
#define | Error_AO_TerminalInvalid (ErrorCodeOffset_AO - 7)
#define | Error_AO_CoupingInvalid (ErrorCodeOffset_AO - 8)
#define | Error_AO_TimeBaseSourceInvalid (ErrorCodeOffset_AO - 9)
#define | Error_AO_SampleClockSourceInvalid (ErrorCodeOffset_AO - 10)
#define | Error_AO_UpdateRateInvalid (ErrorCodeOffset_AO - 11)
#define | Error_AO_UnSupportSampleMode (ErrorCodeOffset_AO - 12)
#define | Error_AO_SamplesToUpdateInvalid (ErrorCodeOffset_AO - 13)
#define | Error_AO_SamplesToUpdateOverRange (ErrorCodeOffset_AO - 14)
#define | Error_AO_ReTriggerCountInvalid (ErrorCodeOffset_AO - 15)
#define | Error_AO_TriggerDelayInvalid (ErrorCodeOffset_AO - 16)
#define | Error_AO_TriggerTypeInvalid (ErrorCodeOffset_AO - 17)
#define | Error_AO_TriggerModeInvalid (ErrorCodeOffset_AO - 18)
#define | Error_AO_DigitalTriggerSourceInvalid (ErrorCodeOffset_AO - 19)
#define | Error_AO_AnalogTriggerSourceInvalid (ErrorCodeOffset_AO - 20)
#define | Error_AO_AnalogTriggerThresholdInvalid (ErrorCodeOffset_AO - 21)
#define | Error_AO_BufferSizeInvalid (ErrorCodeOffset_AO - 22)
#define | Error_AO_DiagnoseFailed (ErrorCodeOffset_AO - 23)
#define | Error_AO_TLastNotAligned (ErrorCodeOffset_AO - 24)
#define | Error_AO_TriggerStateNotMatch (ErrorCodeOffset_AO - 25)
#define | Error_AO_NotStart (ErrorCodeOffset_AO - 26)
#define | Error_AO_WtiteDataTimeOut (ErrorCodeOffset_AO - 27)
#define | Error_AO_BufferPointerIsNull (ErrorCodeOffset_AO - 28)
#define | Error_AO_DataAddressIsNull (ErrorCodeOffset_AO - 29)
#define | Error_AO_BufferUnderflow (ErrorCodeOffset_AO - 30)
#define | Error_AO_TimeOut (ErrorCodeOffset_AO - 31)
#define | Error_AO_PleaseWritedDataBeforeStart (ErrorCodeOffset_AO - 32)
#define | Error_AO_WriteSinglePointFailed (ErrorCodeOffset_AO - 33)
#define | Error_AO_FirstWriteMustGreaterOrEqual_1K_Points (ErrorCodeOffset_AO - 34)
#define | Error_A0_NotSupportWriteDataInCurrentMode (ErrorCodeOffset_AO - 35)
#define | Error_AO_Inter_DACInitFailed (ErrorCodeOffset_AO - 50)
#define | Error_AO_Inter_DACSetChannelFailed (ErrorCodeOffset_AO - 51)
#define | Error_AO_Inter_DACSetSampleRateFailed (ErrorCodeOffset_AO - 52)
#define | Error_AO_Inter_DACEnableAdjustFailed (ErrorCodeOffset_AO - 53)
#define | Error_AO_Inter_DACSetAdjustDataFailed (ErrorCodeOffset_AO - 54)
#define | Error_AO_Inter_DACStartFailed (ErrorCodeOffset_AO - 55)
#define | Error_AO_Inter_DACStoptFailed (ErrorCodeOffset_AO - 56)
#define | Error_AO_Inter_TXInitFailed (ErrorCodeOffset_AO - 57)
#define | Error_AO_Inter_TXClearFailed (ErrorCodeOffset_AO - 58)
#define | ErrorCodeOffset_DI (-10300)
#define | Error_DI_LineNumberInvalid (ErrorCodeOffset_DI - 1)
#define | Error_DI_LineCountInvalid (ErrorCodeOffset_DI - 2)
#define | Error_DI_LineCountOverRang (ErrorCodeOffset_DI - 3)
#define | Error_DI_LineIndexOverRange (ErrorCodeOffset_DI - 4)
#define | Error_DI_PortNumberInvalid (ErrorCodeOffset_DI - 5)
#define | Error_DI_PortCountInvalid (ErrorCodeOffset_DI - 6)
#define | Error_DI_PortCountOverRang (ErrorCodeOffset_DI - 7)
#define | Error_DI_PortIndexOverRange (ErrorCodeOffset_DI - 8)
#define | Error_DI_TimeBaseSourceInvalid (ErrorCodeOffset_DI - 9)
#define | Error_DI_SampleClockSourceInvalid (ErrorCodeOffset_DI - 10)
#define | Error_DI_SampleRateInvalid (ErrorCodeOffset_DI - 11)
#define | Error_DI_UnSupportSampleMode (ErrorCodeOffset_DI - 12)
#define | Error_DI_SamplesToAcquireInvalid (ErrorCodeOffset_DI - 13)
#define | Error_DI_SamplesToAcquireOverRange (ErrorCodeOffset_DI - 14)
#define | Error_DI_SamplesToAcquireNotLessPreTriggerSamples (ErrorCodeOffset_DI - 15)
#define | Error_DI_SampleModeAndTriggerModeNotMatch (ErrorCodeOffset_DI - 16)
#define | Error_DI_PreTriggerSamplesInvalid (ErrorCodeOffset_DI - 17)
#define | Error_DI_ReTriggerCountInvalid (ErrorCodeOffset_DI - 18)
#define | Error_DI_TriggerDelayInvalid (ErrorCodeOffset_DI - 19)
#define | Error_DI_TriggerTypeInvalid (ErrorCodeOffset_DI - 20)
#define | Error_DI_TriggerModeInvalid (ErrorCodeOffset_DI - 21)
#define | Error_DI_DigitalTriggerSourceInvalid (ErrorCodeOffset_DI - 22)
#define | Error_DI_BufferSizeInvalid (ErrorCodeOffset_DI - 23)
#define | Error_DI_DiagnoseFailed (ErrorCodeOffset_DI - 24)
#define | Error_DI_TLastNotAligned (ErrorCodeOffset_DI - 25)
#define | Error_DI_TriggerStateNotMatch (ErrorCodeOffset_DI - 26)
#define | Error_DI_NotStart (ErrorCodeOffset_DI - 27)
#define | Error_DI_ReadDataTimeOut (ErrorCodeOffset_DI - 28)
#define | Error_DI_BufferPointerIsNull (ErrorCodeOffset_DI - 29)
#define | Error_DI_DataAddressIsNull (ErrorCodeOffset_DI - 30)
#define | Error_DI_BufferOverflow (ErrorCodeOffset_DI - 31)
#define | Error_DI_TimeOut (ErrorCodeOffset_DI - 32)
#define | Error_DI_ReadSinglePortFailed (ErrorCodeOffset_DI - 33)
#define | Error_DI_ExternalTimeBaseSampleRateInvalid (ErrorCodeOffset_DI - 34)
#define | Error_DI_WatchDogTimerRunning (ErrorCodeOffset_DI - 35)
#define | Error_WatchdogAlreadyStarted (ErrorCodeOffset_DI - 50)
#define | Error_WatchdogAlreadyStoped (ErrorCodeOffset_DI - 51)
#define | Error_ChangeDetectionAlreadyEnabled (ErrorCodeOffset_DI - 52)
#define | Error_ChangeDetectionStopTimeout (ErrorCodeOffset_DI - 53)
#define | Error_ChangeDetectionThreadIsRunning (ErrorCodeOffset_DI - 54)
#define | ErrorCodeOffset_DO (-10400)
#define | Error_DO_LineNumberInvalid (ErrorCodeOffset_DO - 1)
#define | Error_DO_LineCountInvalid (ErrorCodeOffset_DO - 2)
#define | Error_DO_LineCountOverRang (ErrorCodeOffset_DO - 3)
#define | Error_DO_LineIndexOverRange (ErrorCodeOffset_DO - 4)
#define | Error_DO_PortNumberInvalid (ErrorCodeOffset_DO - 5)
#define | Error_DO_PortCountInvalid (ErrorCodeOffset_DO - 6)
#define | Error_DO_PortCountOverRang (ErrorCodeOffset_DO - 7)
#define | Error_DO_PortIndexOverRange (ErrorCodeOffset_DO - 8)
#define | Error_DO_TimeBaseSourceInvalid (ErrorCodeOffset_DO - 9)
#define | Error_DO_SampleClockSourceInvalid (ErrorCodeOffset_DO - 10)
#define | Error_DO_UpdateRateInvalid (ErrorCodeOffset_DO - 11)
#define | Error_DO_UnSupportSampleMode (ErrorCodeOffset_DO - 12)
#define | Error_DO_SamplesToUpdateInvalid (ErrorCodeOffset_DO - 13)
#define | Error_DO_SamplesToUpdateOverRange (ErrorCodeOffset_DO - 14)
#define | Error_DO_ReTriggerCountInvalid (ErrorCodeOffset_DO - 15)
#define | Error_DO_TriggerDelayInvalid (ErrorCodeOffset_DO - 16)
#define | Error_DO_TriggerTypeInvalid (ErrorCodeOffset_DO - 17)
#define | Error_DO_TriggerModeInvalid (ErrorCodeOffset_DO - 18)
#define | Error_DO_DigitalTriggerSourceInvalid (ErrorCodeOffset_DO - 19)
#define | Error_DO_BufferSizeInvalid (ErrorCodeOffset_DO - 20)
#define | Error_DO_DiagnoseFailed (ErrorCodeOffset_DO - 21)
#define | Error_DO_TLastNotAligned (ErrorCodeOffset_DO - 22)
#define | Error_DO_TriggerStateNotMatch (ErrorCodeOffset_DO - 23)
#define | Error_DO_NotStart (ErrorCodeOffset_DO - 24)
#define | Error_DO_WtiteDataTimeOut (ErrorCodeOffset_DO - 25)
#define | Error_DO_BufferPointerIsNull (ErrorCodeOffset_DO - 26)
#define | Error_DO_DataAddressIsNull (ErrorCodeOffset_DO - 27)
#define | Error_DO_BufferUnderflow (ErrorCodeOffset_DO - 28)
#define | Error_DO_TimeOut (ErrorCodeOffset_DO - 29)
#define | Error_DO_PleaseWritedDataBeforeStart (ErrorCodeOffset_DO - 30)
#define | Error_DO_WriteSinglePortFailed (ErrorCodeOffset_DO - 31)
#define | Error_DO_ExternalTimeBaseUpdateRateInvalid (ErrorCodeOffset_DO - 32)
#define | Error_DO_FirstWriteMustGreaterOrEqual_1K_Points (ErrorCodeOffset_DO - 33)
#define | Error_DO_Inter_TXInitFailed (ErrorCodeOffset_DO - 50)
#define | ErrorCodeOffset_CIO (-10500)
#define | Error_CIO_ChannelInvalid (ErrorCodeOffset_CIO - 1)
#define | Error_CIO_ChannelIsReserved (ErrorCodeOffset_CIO - 2)
#define | Error_CIO_ConfigInitCountFailed (ErrorCodeOffset_CIO - 3)
#define | Error_CIO_ConfigDirectionFailed (ErrorCodeOffset_CIO - 4)
#define | Error_CIO_ConfigCounterTypeFailed (ErrorCodeOffset_CIO - 5)
#define | Error_CIO__TimeBaseSourceInvalid (ErrorCodeOffset_CIO - 6)
#define | Error_CIO_SampleClockSourceInvalid (ErrorCodeOffset_CIO - 7)
#define | Error_CIO_SampleRateInvalid (ErrorCodeOffset_CIO - 8)
#define | Error_CIO_UnSupportSampleMode (ErrorCodeOffset_CIO - 9)
#define | Error_CIO_SamplesToAcquireInvalid (ErrorCodeOffset_CIO - 10)
#define | Error_CIO_SamplesToAcquireOverRange (ErrorCodeOffset_CIO - 11)
#define | Error_CIO_SamplesToAcquireNotLessPreTriggerSamples (ErrorCodeOffset_CIO - 12)
#define | Error_CIO_SampleModeAndTriggerModeNotMatch (ErrorCodeOffset_CIO - 13)
#define | Error_CIO_PreTriggerSamplesInvalid (ErrorCodeOffset_CIO - 14)
#define | Error_CIO_ReTriggerCountInvalid (ErrorCodeOffset_CIO - 15)
#define | Error_CIO_TriggerDelayInvalid (ErrorCodeOffset_CIO - 16)
#define | Error_CIO_TriggerTypeInvalid (ErrorCodeOffset_CIO - 17)
#define | Error_CIO_TriggerModeInvalid (ErrorCodeOffset_CIO - 18)
#define | Error_CIO_DigitalTriggerSourceInvalid (ErrorCodeOffset_CIO - 19)
#define | Error_CIO_SampleModeDoesNotSupportFrequencyOrPeriodMeasure (ErrorCodeOffset_CIO - 20)
#define | Error_CIO_ConfigInitDelayFailed (ErrorCodeOffset_CIO - 21)
#define | Error_CIO_ConfigIdleStateFailed (ErrorCodeOffset_CIO - 22)
#define | Error_CIO_ClockTypeDoesNotSupportFrequencyOrPeriodMeasure (ErrorCodeOffset_CIO - 23)
#define | Error_CIO_Inter_ReadFrequencyOrPeriodMeasureDataInvalid (ErrorCodeOffset_CIO - 24)
#define | Error_CIO_ReadValueTimeOut (ErrorCodeOffset_CIO - 25)
#define | Error_CIO_NoDataWrittenYet (ErrorCodeOffset_CIO - 26)
#define | Error_CIO_SetWorkModeFailed (ErrorCodeOffset_CIO - 27)
#define | Error_CIO_SampleModeDoesNotSupportEncoder (ErrorCodeOffset_CIO - 28)
#define | Error_CIO_DelayTooShort (ErrorCodeOffset_CIO - 29)
#define | Error_CIO_TimebaseConfigFailed (ErrorCodeOffset_CIO - 30)
#define | Error_CIO_ConfigReverseFailed (ErrorCodeOffset_CIO - 31)
#define | Error_CIO_ReadValueFailed (ErrorCodeOffset_CIO - 32)
#define | Error_CIO_BufferOverflow (ErrorCodeOffset_CIO - 33)
#define | Error_CIO_PleaseWritedDataBeforeStart (ErrorCodeOffset_CIO - 34)
#define | Error_CIO_NotStart (ErrorCodeOffset_CIO - 35)
#define | Error_CIO_ClockTypeDoesNotSupportMeasureType (ErrorCodeOffset_CIO - 36)
#define | Error_CIO_Inter_RXInitFailed (ErrorCodeOffset_CIO - 50)
#define | Error_CIO_Inter_TXInitFailed (ErrorCodeOffset_CIO - 51)
#define | ErrorCodeOffset_PFI (-10600)
#define | Error_DIO_LineIsReserved (ErrorCodeOffset_PFI - 1)
#define | Error_PFI_LineInvalid (ErrorCodeOffset_PFI - 2)
#define | Error_PFI_LineIsReserved (ErrorCodeOffset_PFI - 3)
#define | Error_PXITrgger_LineInvalid (ErrorCodeOffset_PFI - 4)
#define | Error_PXITrgger_LineIsReserved (ErrorCodeOffset_PFI - 5)
#define | Error_PFI_FilterPulseWidthOverflow (ErrorCodeOffset_PFI - 6)
#define | FD_ANALOG_TRIGGER_ERROR_CODE_OFFSET (-100)
#define | FD_ANALOG_TRIGGER_POINT_IS_NULL ((-1)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))
#define | FD_ANALOG_TRIGGER_THRESHOLD_PARAM_OUT_RANGE ((-2)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))
#define | FD_ANALOG_TRIGGER_MODESEL_PARAM_OUT_RANGE ((-3)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))
#define | FD_ANALOG_TRIGGER_REG_WRITE_FAILED ((-4)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))
#define | FD_ANALOG_TRIGGER_DUMP_REG_READ_FAILED ((-5)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))
#define | FD_ANALOG_TRIGGER_PARALLEL_BYTES_UNSUPPORTED ((-6)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))
#define | FD_ANALOG_TRIGGER_INPUT_DATA_WIDTH_UNREASONABLE ((-7)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))
#define | FD_COUNTER_ERROR_CODE_OFFSET (-200)
#define | FD_COUNTER_POINT_IS_NULL ((-1)+(COUNTER_ERROR_CODE_OFFSET))
#define | FD_COUNTER_REG_WRITE_FAILED ((-2)+(COUNTER_ERROR_CODE_OFFSET))
#define | FD_COUNTER_DUMP_REG_READ_FAILED ((-3)+(COUNTER_ERROR_CODE_OFFSET))
#define | FD_COUNTER_PARAM_OUT_RANGE ((-4)+(COUNTER_ERROR_CODE_OFFSET))
#define | FD_COUNTER_IP_PARAM_ERROR ((-5)+(COUNTER_ERROR_CODE_OFFSET))
#define | FD_COUNTER_VERSION_NOT_MATCH ((-6)+(COUNTER_ERROR_CODE_OFFSET))
#define | FD_PARALLELDI_ERROR_CODE_OFFSET (-400)
#define | FD_PARALLELDI_POINT_IS_NULL ((-1)+(PARALLELDI_ERROR_CODE_OFFSET))
#define | FD_PARALLELDI_PARAM_OUT_RANGE ((-2)+(PARALLELDI_ERROR_CODE_OFFSET))
#define | FD_PARALLELDI_REG_WRITE_FAILED ((-3)+(PARALLELDI_ERROR_CODE_OFFSET))
#define | FD_PARALLELDI_DUMP_REG_READ_FAILED ((-4)+(PARALLELDI_ERROR_CODE_OFFSET))
#define | FD_PARALLELDO_ERROR_CODE_OFFSET (-500)
#define | FD_PARALLELDO_POINT_IS_NULL ((-1)+(PARALLELDO_ERROR_CODE_OFFSET))
#define | FD_PARALLELDO_PARAM_OUT_RANGE ((-2)+(PARALLELDO_ERROR_CODE_OFFSET))
#define | FD_PARALLELDO_REG_WRITE_FAILED ((-3)+(PARALLELDO_ERROR_CODE_OFFSET))
#define | FD_PARALLELDO_DUMP_REG_READ_FAILED ((-4)+(PARALLELDO_ERROR_CODE_OFFSET))
#define | FD_PFI_ERROR_CODE_OFFSET (-800)
#define | FD_PFI_INIT_REG_WRITE_FAILED ((-1)+(PFI_ERROR_CODE_OFFSET))
#define | FD_PFI_DUMP_REG_READ_FAILED ((-2)+(PFI_ERROR_CODE_OFFSET))
#define | FD_PFI_PARAM_OUT_OF_RANG ((-3)+(PFI_ERROR_CODE_OFFSET))
#define | FD_PFI_POINT_IS_NULL ((-4)+(PFI_ERROR_CODE_OFFSET))
#define | FD_PFI_IP_DISABLEFILTER ((-5)+(PFI_ERROR_CODE_OFFSET))
#define | FD_RoutingMatrix_ERROR_CODE_OFFSET (-1000)
#define | FD_RoutingMatrix_PARAM_OUT_OF_RANGE ((-1)+(RoutingMatrix_ERROR_CODE_OFFSET))
#define | FD_RoutingMatrix_REG_WRITE_FAILED ((-2)+(RoutingMatrix_ERROR_CODE_OFFSET))
#define | FD_RoutingMatrix_DUMP_REG_READ_FAILED ((-3)+(RoutingMatrix_ERROR_CODE_OFFSET))
#define | FD_RoutingMatrix_POINT_IS_NULL ((-4)+(RoutingMatrix_ERROR_CODE_OFFSET))
#define | FD_RX_ENGINE_ERROR_CODE_BASE (-1100)
#define | FD_RX_ENGINE_HW_TRIIGER_UNENABLED (RX_ENGINE_ERROR_CODE_BASE - 0)
#define | FD_RX_ENGINE_FPGA_MEMORY_OVERFLOW (RX_ENGINE_ERROR_CODE_BASE - 1)
#define | FD_RX_ENGINE_CHANNEL_CONFIGURATION_ERROR (RX_ENGINE_ERROR_CODE_BASE - 2)
#define | FD_RX_ENGINE_NO_REFERENCE_TRIGGER (RX_ENGINE_ERROR_CODE_BASE - 3)
#define | FD_RX_ENGINE_DATAMOVER_ERROR (RX_ENGINE_ERROR_CODE_BASE - 4)
#define | FD_RX_FINITE_TRANSFER_IS_NOT_FINISHED (RX_ENGINE_ERROR_CODE_BASE - 5)
#define | FD_RX_ENGINE_TIME_EXPIRED (RX_ENGINE_ERROR_CODE_BASE - 6)
#define | FD_RX_ENGINE_PARAMETER_INVALID (RX_ENGINE_ERROR_CODE_BASE - 7)
#define | FD_RX_ENGINE_INPUT_INFORMATION_IS_NULL (RX_ENGINE_ERROR_CODE_BASE - 8)
#define | FD_RX_ENGINE_COMMAND_STATE_NOT_MATTH (RX_ENGINE_ERROR_CODE_BASE - 9)
#define | FD_RX_DATA_FORMAT_IS_NOT_RIGHT (RX_ENGINE_ERROR_CODE_BASE - 10)
#define | FD_RX_ENGINE_BYTE_MASK_MUST_BE_UNZERO (RX_ENGINE_ERROR_CODE_BASE - 12)
#define | FD_RX_ENGINE_SAMPLE_BYTES_IS_ZERO (RX_ENGINE_ERROR_CODE_BASE - 13)
#define | FD_RX_ENGINE_DATA_BUFFER_LENGTH_WRONG (RX_ENGINE_ERROR_CODE_BASE - 14)
#define | FD_RX_ENGINE_SAMPLE_RATE_IS_TOO_BIG (RX_ENGINE_ERROR_CODE_BASE - 15)
#define | FD_RX_ENGINE_FPGA_DATA_MOVER_ERROR (RX_ENGINE_ERROR_CODE_BASE - 16)
#define | FD_RX_ENGINE_SMPLESIZE_IN_BYTES_ERROR (RX_ENGINE_ERROR_CODE_BASE - 17)
#define | FD_RX_ENGINE_DATA_MOVER_RATE_SLOW_ERROR (RX_ENGINE_ERROR_CODE_BASE - 18)
#define | FD_RX_ENGINE_USER_DEFINED_START_READ_POINTER_UNRESONABLE (RX_ENGINE_ERROR_CODE_BASE - 19)
#define | FD_TX_ENGINE_ERROR_CODE_BASE -1200
#define | FD_TX_ENGINE_TIME_EXPIRED (TX_ENGINE_ERROR_CODE_BASE - 1)
#define | FD_TX_ENGINE_UNDERFLOW (TX_ENGINE_ERROR_CODE_BASE - 2)
#define | FD_TX_ENGINE_STROBE_IS_ZERO (TX_ENGINE_ERROR_CODE_BASE - 3)
#define | FD_TX_ENGINE_MEMORYSIZE_UNEQUAL_SENDBYTES (TX_ENGINE_ERROR_CODE_BASE - 4)
#define | FD_TX_ENGINE_DATA_MOVER_ERROR (TX_ENGINE_ERROR_CODE_BASE - 5)
#define | FD_TX_ENGINE_DATA_WRITE_POINTER_UNDERFLOW (TX_ENGINE_ERROR_CODE_BASE - 6)
#define | FD_TX_ENGINE_DATA_MULTIRECORD_OVERFLOW (TX_ENGINE_ERROR_CODE_BASE - 7)
#define | FD_TX_ENGINE_INPUT_INFORMATION_IS_NULL (TX_ENGINE_ERROR_CODE_BASE - 8)
#define | FD_TX_ENGINE_COMMAND_STATE_NOT_MATTH (TX_ENGINE_ERROR_CODE_BASE - 9)
#define | FD_TX_ENGINE_SAMPLE_ELEMENTSIZE_IS_ZERO (TX_ENGINE_ERROR_CODE_BASE - 10)
#define | FD_TX_ENGINE_OUTPUT_DATA_WIDTH_READ_ERROR (TX_ENGINE_ERROR_CODE_BASE - 11)
#define | FD_TX_ENGINE_INPUT_SERIAL_PARALLEL_MUTEX (TX_ENGINE_ERROR_CODE_BASE - 12)
#define | FD_TX_ENGINE_SAMPLE_BYTES_IS_ZERO (TX_ENGINE_ERROR_CODE_BASE - 13)
#define | FD_TX_ENGINE_DATA_BUFFER_LENGTH_WRONG (TX_ENGINE_ERROR_CODE_BASE - 14)
#define | FD_TX_ENGINE_SAMPLE_RATE_IS_TOO_BIG (TX_ENGINE_ERROR_CODE_BASE - 15)
#define | FD_TX_ENGINE_UPDATE_RATE_NOT_ENOUGH_ERROR (TX_ENGINE_ERROR_CODE_BASE - 16)
#define | FD_CLK_ENDPOINTS_NOT_SOPPOUTED -3000-1
#define | FD_PLL_DYNAMIC_BASE_ERROR_CODE -100000
#define | FD_PLL_DYNAMIC_UNLOCKED PLL_DYNAMIC_BASE_ERROR_CODE|1
#define | FD_PLL_DYNAMIC_VCO_OUT_RANFE PLL_DYNAMIC_BASE_ERROR_CODE|2
#define | FD_PLL_DYNAMIC_INPUT_OUTRANGE PLL_DYNAMIC_BASE_ERROR_CODE|3
#define | FD_PLL_DYNAMIC_PFD_OUTRANGE PLL_DYNAMIC_BASE_ERROR_CODE|4
#define | FD_PLL_DYNAMIC_OUT_OUTRANGE PLL_DYNAMIC_BASE_ERROR_CODE|5

Macro Definition Documentation

◆ Error_A0_NotSupportWriteDataInCurrentMode

#define Error_A0_NotSupportWriteDataInCurrentMode (ErrorCodeOffset_AO - 35)

◆ Error_ActiveDeviceFailed

#define Error_ActiveDeviceFailed (ErrorCodeOffset - 5)

◆ Error_AI_AnalogTriggerNoSupportStartTriggerMode

#define Error_AI_AnalogTriggerNoSupportStartTriggerMode (ErrorCodeOffset_AI - 40)

◆ Error_AI_AnalogTriggerSourceInvalid

#define Error_AI_AnalogTriggerSourceInvalid (ErrorCodeOffset_AI - 27)

◆ Error_AI_AnalogTriggerThresholdInvalid

#define Error_AI_AnalogTriggerThresholdInvalid (ErrorCodeOffset_AI - 28)

◆ Error_AI_AnalogTriggerThresholdOverRange

#define Error_AI_AnalogTriggerThresholdOverRange (ErrorCodeOffset_AI - 39)

◆ Error_AI_BufferOverflow

#define Error_AI_BufferOverflow (ErrorCodeOffset_AI - 37)

◆ Error_AI_BufferPointerIsNull

#define Error_AI_BufferPointerIsNull (ErrorCodeOffset_AI - 35)

◆ Error_AI_BufferSizeInvalid

#define Error_AI_BufferSizeInvalid (ErrorCodeOffset_AI - 29)

◆ Error_AI_ChannelCountInvalid

#define Error_AI_ChannelCountInvalid (ErrorCodeOffset_AI - 2)

◆ Error_AI_ChannelCountOverRang

#define Error_AI_ChannelCountOverRang (ErrorCodeOffset_AI - 3)

◆ Error_AI_ChannelIndexOverRange

#define Error_AI_ChannelIndexOverRange (ErrorCodeOffset_AI - 4)

◆ Error_AI_ChannelNumberInvalid

#define Error_AI_ChannelNumberInvalid (ErrorCodeOffset_AI - 1)

◆ Error_AI_ConvertClockSourceInvalid

#define Error_AI_ConvertClockSourceInvalid (ErrorCodeOffset_AI - 14)

◆ Error_AI_ConvertRateInvalid

#define Error_AI_ConvertRateInvalid (ErrorCodeOffset_AI - 15)

◆ Error_AI_CoupingInvalid

#define Error_AI_CoupingInvalid (ErrorCodeOffset_AI - 10)

◆ Error_AI_CurrentRangeInvalid

#define Error_AI_CurrentRangeInvalid (ErrorCodeOffset_AI - 6)

◆ Error_AI_DataAddressIsNull

#define Error_AI_DataAddressIsNull (ErrorCodeOffset_AI - 36)

◆ Error_AI_DiagnoseFailed

#define Error_AI_DiagnoseFailed (ErrorCodeOffset_AI - 30)

◆ Error_AI_DigitalTriggerSourceInvalid

#define Error_AI_DigitalTriggerSourceInvalid (ErrorCodeOffset_AI - 26)

◆ Error_AI_DSModeSampleRateInvalid

#define Error_AI_DSModeSampleRateInvalid (ErrorCodeOffset_AI - 42)

◆ Error_AI_ExternalSampleRateOverRange

#define Error_AI_ExternalSampleRateOverRange (ErrorCodeOffset_AI - 43)

◆ Error_AI_Inter_ADCEnableAdjustFailed

#define Error_AI_Inter_ADCEnableAdjustFailed (ErrorCodeOffset_AI - 53)

◆ Error_AI_Inter_ADCInitFailed

#define Error_AI_Inter_ADCInitFailed (ErrorCodeOffset_AI - 50)

◆ Error_AI_Inter_ADCSetAdjustDataFailed

#define Error_AI_Inter_ADCSetAdjustDataFailed (ErrorCodeOffset_AI - 54)

◆ Error_AI_Inter_ADCSetChannelFailed

#define Error_AI_Inter_ADCSetChannelFailed (ErrorCodeOffset_AI - 51)

◆ Error_AI_Inter_ADCSetSampleRateFailed

#define Error_AI_Inter_ADCSetSampleRateFailed (ErrorCodeOffset_AI - 52)

◆ Error_AI_Inter_ADCStartFailed

#define Error_AI_Inter_ADCStartFailed (ErrorCodeOffset_AI - 55)

◆ Error_AI_Inter_ADCStoptFailed

#define Error_AI_Inter_ADCStoptFailed (ErrorCodeOffset_AI - 56)

◆ Error_AI_Inter_RXInitFailed

#define Error_AI_Inter_RXInitFailed (ErrorCodeOffset_AI - 57)

◆ Error_AI_NotStart

#define Error_AI_NotStart (ErrorCodeOffset_AI - 33)

◆ Error_AI_PreTriggerSamplesInvalid

#define Error_AI_PreTriggerSamplesInvalid (ErrorCodeOffset_AI - 21)

◆ Error_AI_PreTriggerSamplesMustBeGreaterThanZero

#define Error_AI_PreTriggerSamplesMustBeGreaterThanZero (ErrorCodeOffset_AI - 41)

◆ Error_AI_ReadDataTimeOut

#define Error_AI_ReadDataTimeOut (ErrorCodeOffset_AI - 34)

◆ Error_AI_ResistanceRangeInvalid

#define Error_AI_ResistanceRangeInvalid (ErrorCodeOffset_AI - 7)

◆ Error_AI_ReTriggerCountInvalid

#define Error_AI_ReTriggerCountInvalid (ErrorCodeOffset_AI - 22)

◆ Error_AI_RTDTopologyTypeInvalid

#define Error_AI_RTDTopologyTypeInvalid (ErrorCodeOffset_AI - 8)

◆ Error_AI_SampleClockSourceInvalid

#define Error_AI_SampleClockSourceInvalid (ErrorCodeOffset_AI - 12)

◆ Error_AI_SampleModeAndTriggerModeNotMatch

#define Error_AI_SampleModeAndTriggerModeNotMatch (ErrorCodeOffset_AI - 20)

◆ Error_AI_SampleRateInvalid

#define Error_AI_SampleRateInvalid (ErrorCodeOffset_AI - 13)

◆ Error_AI_SamplesToAcquireInvalid

#define Error_AI_SamplesToAcquireInvalid (ErrorCodeOffset_AI - 17)

◆ Error_AI_SamplesToAcquireNotLessPreTriggerSamples

#define Error_AI_SamplesToAcquireNotLessPreTriggerSamples (ErrorCodeOffset_AI - 19)

◆ Error_AI_SamplesToAcquireOverRange

#define Error_AI_SamplesToAcquireOverRange (ErrorCodeOffset_AI - 18)

◆ Error_AI_TerminalInvalid

#define Error_AI_TerminalInvalid (ErrorCodeOffset_AI - 9)

◆ Error_AI_TimeBaseSourceInvalid

#define Error_AI_TimeBaseSourceInvalid (ErrorCodeOffset_AI - 11)

◆ Error_AI_TimeOut

#define Error_AI_TimeOut (ErrorCodeOffset_AI - 38)

◆ Error_AI_TLastNotAligned

#define Error_AI_TLastNotAligned (ErrorCodeOffset_AI - 31)

◆ Error_AI_TriggerDelayInvalid

#define Error_AI_TriggerDelayInvalid (ErrorCodeOffset_AI - 23)

◆ Error_AI_TriggerModeInvalid

#define Error_AI_TriggerModeInvalid (ErrorCodeOffset_AI - 25)

◆ Error_AI_TriggerStateNotMatch

#define Error_AI_TriggerStateNotMatch (ErrorCodeOffset_AI - 32)

◆ Error_AI_TriggerTypeInvalid

#define Error_AI_TriggerTypeInvalid (ErrorCodeOffset_AI - 24)

◆ Error_AI_UnSupportSampleMode

#define Error_AI_UnSupportSampleMode (ErrorCodeOffset_AI - 16)

◆ Error_AI_VoltageRangInvalid

#define Error_AI_VoltageRangInvalid (ErrorCodeOffset_AI - 5)

◆ Error_AO_AnalogTriggerSourceInvalid

#define Error_AO_AnalogTriggerSourceInvalid (ErrorCodeOffset_AO - 20)

◆ Error_AO_AnalogTriggerThresholdInvalid

#define Error_AO_AnalogTriggerThresholdInvalid (ErrorCodeOffset_AO - 21)

◆ Error_AO_BufferPointerIsNull

#define Error_AO_BufferPointerIsNull (ErrorCodeOffset_AO - 28)

◆ Error_AO_BufferSizeInvalid

#define Error_AO_BufferSizeInvalid (ErrorCodeOffset_AO - 22)

◆ Error_AO_BufferUnderflow

#define Error_AO_BufferUnderflow (ErrorCodeOffset_AO - 30)

◆ Error_AO_ChannelCountInvalid

#define Error_AO_ChannelCountInvalid (ErrorCodeOffset_AO - 2)

◆ Error_AO_ChannelCountOverRang

#define Error_AO_ChannelCountOverRang (ErrorCodeOffset_AO - 3)

◆ Error_AO_ChannelIndexOverRange

#define Error_AO_ChannelIndexOverRange (ErrorCodeOffset_AO - 4)

◆ Error_AO_ChannelNumberInvalid

#define Error_AO_ChannelNumberInvalid (ErrorCodeOffset_AO - 1)

◆ Error_AO_CoupingInvalid

#define Error_AO_CoupingInvalid (ErrorCodeOffset_AO - 8)

◆ Error_AO_CurrentRangeInvalid

#define Error_AO_CurrentRangeInvalid (ErrorCodeOffset_AO - 6)

◆ Error_AO_DataAddressIsNull

#define Error_AO_DataAddressIsNull (ErrorCodeOffset_AO - 29)

◆ Error_AO_DiagnoseFailed

#define Error_AO_DiagnoseFailed (ErrorCodeOffset_AO - 23)

◆ Error_AO_DigitalTriggerSourceInvalid

#define Error_AO_DigitalTriggerSourceInvalid (ErrorCodeOffset_AO - 19)

◆ Error_AO_FirstWriteMustGreaterOrEqual_1K_Points

#define Error_AO_FirstWriteMustGreaterOrEqual_1K_Points (ErrorCodeOffset_AO - 34)

◆ Error_AO_Inter_DACEnableAdjustFailed

#define Error_AO_Inter_DACEnableAdjustFailed (ErrorCodeOffset_AO - 53)

◆ Error_AO_Inter_DACInitFailed

#define Error_AO_Inter_DACInitFailed (ErrorCodeOffset_AO - 50)

◆ Error_AO_Inter_DACSetAdjustDataFailed

#define Error_AO_Inter_DACSetAdjustDataFailed (ErrorCodeOffset_AO - 54)

◆ Error_AO_Inter_DACSetChannelFailed

#define Error_AO_Inter_DACSetChannelFailed (ErrorCodeOffset_AO - 51)

◆ Error_AO_Inter_DACSetSampleRateFailed

#define Error_AO_Inter_DACSetSampleRateFailed (ErrorCodeOffset_AO - 52)

◆ Error_AO_Inter_DACStartFailed

#define Error_AO_Inter_DACStartFailed (ErrorCodeOffset_AO - 55)

◆ Error_AO_Inter_DACStoptFailed

#define Error_AO_Inter_DACStoptFailed (ErrorCodeOffset_AO - 56)

◆ Error_AO_Inter_TXClearFailed

#define Error_AO_Inter_TXClearFailed (ErrorCodeOffset_AO - 58)

◆ Error_AO_Inter_TXInitFailed

#define Error_AO_Inter_TXInitFailed (ErrorCodeOffset_AO - 57)

◆ Error_AO_NotStart

#define Error_AO_NotStart (ErrorCodeOffset_AO - 26)

◆ Error_AO_PleaseWritedDataBeforeStart

#define Error_AO_PleaseWritedDataBeforeStart (ErrorCodeOffset_AO - 32)

◆ Error_AO_ReTriggerCountInvalid

#define Error_AO_ReTriggerCountInvalid (ErrorCodeOffset_AO - 15)

◆ Error_AO_SampleClockSourceInvalid

#define Error_AO_SampleClockSourceInvalid (ErrorCodeOffset_AO - 10)

◆ Error_AO_SamplesToUpdateInvalid

#define Error_AO_SamplesToUpdateInvalid (ErrorCodeOffset_AO - 13)

◆ Error_AO_SamplesToUpdateOverRange

#define Error_AO_SamplesToUpdateOverRange (ErrorCodeOffset_AO - 14)

◆ Error_AO_TerminalInvalid

#define Error_AO_TerminalInvalid (ErrorCodeOffset_AO - 7)

◆ Error_AO_TimeBaseSourceInvalid

#define Error_AO_TimeBaseSourceInvalid (ErrorCodeOffset_AO - 9)

◆ Error_AO_TimeOut

#define Error_AO_TimeOut (ErrorCodeOffset_AO - 31)

◆ Error_AO_TLastNotAligned

#define Error_AO_TLastNotAligned (ErrorCodeOffset_AO - 24)

◆ Error_AO_TriggerDelayInvalid

#define Error_AO_TriggerDelayInvalid (ErrorCodeOffset_AO - 16)

◆ Error_AO_TriggerModeInvalid

#define Error_AO_TriggerModeInvalid (ErrorCodeOffset_AO - 18)

◆ Error_AO_TriggerStateNotMatch

#define Error_AO_TriggerStateNotMatch (ErrorCodeOffset_AO - 25)

◆ Error_AO_TriggerTypeInvalid

#define Error_AO_TriggerTypeInvalid (ErrorCodeOffset_AO - 17)

◆ Error_AO_UnSupportSampleMode

#define Error_AO_UnSupportSampleMode (ErrorCodeOffset_AO - 12)

◆ Error_AO_UpdateRateInvalid

#define Error_AO_UpdateRateInvalid (ErrorCodeOffset_AO - 11)

◆ Error_AO_VoltageRangInvalid

#define Error_AO_VoltageRangInvalid (ErrorCodeOffset_AO - 5)

◆ Error_AO_WriteSinglePointFailed

#define Error_AO_WriteSinglePointFailed (ErrorCodeOffset_AO - 33)

◆ Error_AO_WtiteDataTimeOut

#define Error_AO_WtiteDataTimeOut (ErrorCodeOffset_AO - 27)

◆ Error_ChangeDetectionAlreadyEnabled

#define Error_ChangeDetectionAlreadyEnabled (ErrorCodeOffset_DI - 52)

◆ Error_ChangeDetectionStopTimeout

#define Error_ChangeDetectionStopTimeout (ErrorCodeOffset_DI - 53)

◆ Error_ChangeDetectionThreadIsRunning

#define Error_ChangeDetectionThreadIsRunning (ErrorCodeOffset_DI - 54)

◆ Error_CIO__TimeBaseSourceInvalid

#define Error_CIO__TimeBaseSourceInvalid (ErrorCodeOffset_CIO - 6)

◆ Error_CIO_BufferOverflow

#define Error_CIO_BufferOverflow (ErrorCodeOffset_CIO - 33)

◆ Error_CIO_ChannelInvalid

#define Error_CIO_ChannelInvalid (ErrorCodeOffset_CIO - 1)

◆ Error_CIO_ChannelIsReserved

#define Error_CIO_ChannelIsReserved (ErrorCodeOffset_CIO - 2)

◆ Error_CIO_ClockTypeDoesNotSupportFrequencyOrPeriodMeasure

#define Error_CIO_ClockTypeDoesNotSupportFrequencyOrPeriodMeasure (ErrorCodeOffset_CIO - 23)

◆ Error_CIO_ClockTypeDoesNotSupportMeasureType

#define Error_CIO_ClockTypeDoesNotSupportMeasureType (ErrorCodeOffset_CIO - 36)

◆ Error_CIO_ConfigCounterTypeFailed

#define Error_CIO_ConfigCounterTypeFailed (ErrorCodeOffset_CIO - 5)

◆ Error_CIO_ConfigDirectionFailed

#define Error_CIO_ConfigDirectionFailed (ErrorCodeOffset_CIO - 4)

◆ Error_CIO_ConfigIdleStateFailed

#define Error_CIO_ConfigIdleStateFailed (ErrorCodeOffset_CIO - 22)

◆ Error_CIO_ConfigInitCountFailed

#define Error_CIO_ConfigInitCountFailed (ErrorCodeOffset_CIO - 3)

◆ Error_CIO_ConfigInitDelayFailed

#define Error_CIO_ConfigInitDelayFailed (ErrorCodeOffset_CIO - 21)

◆ Error_CIO_ConfigReverseFailed

#define Error_CIO_ConfigReverseFailed (ErrorCodeOffset_CIO - 31)

◆ Error_CIO_DelayTooShort

#define Error_CIO_DelayTooShort (ErrorCodeOffset_CIO - 29)

◆ Error_CIO_DigitalTriggerSourceInvalid

#define Error_CIO_DigitalTriggerSourceInvalid (ErrorCodeOffset_CIO - 19)

◆ Error_CIO_Inter_ReadFrequencyOrPeriodMeasureDataInvalid

#define Error_CIO_Inter_ReadFrequencyOrPeriodMeasureDataInvalid (ErrorCodeOffset_CIO - 24)

◆ Error_CIO_Inter_RXInitFailed

#define Error_CIO_Inter_RXInitFailed (ErrorCodeOffset_CIO - 50)

◆ Error_CIO_Inter_TXInitFailed

#define Error_CIO_Inter_TXInitFailed (ErrorCodeOffset_CIO - 51)

◆ Error_CIO_NoDataWrittenYet

#define Error_CIO_NoDataWrittenYet (ErrorCodeOffset_CIO - 26)

◆ Error_CIO_NotStart

#define Error_CIO_NotStart (ErrorCodeOffset_CIO - 35)

◆ Error_CIO_PleaseWritedDataBeforeStart

#define Error_CIO_PleaseWritedDataBeforeStart (ErrorCodeOffset_CIO - 34)

◆ Error_CIO_PreTriggerSamplesInvalid

#define Error_CIO_PreTriggerSamplesInvalid (ErrorCodeOffset_CIO - 14)

◆ Error_CIO_ReadValueFailed

#define Error_CIO_ReadValueFailed (ErrorCodeOffset_CIO - 32)

◆ Error_CIO_ReadValueTimeOut

#define Error_CIO_ReadValueTimeOut (ErrorCodeOffset_CIO - 25)

◆ Error_CIO_ReTriggerCountInvalid

#define Error_CIO_ReTriggerCountInvalid (ErrorCodeOffset_CIO - 15)

◆ Error_CIO_SampleClockSourceInvalid

#define Error_CIO_SampleClockSourceInvalid (ErrorCodeOffset_CIO - 7)

◆ Error_CIO_SampleModeAndTriggerModeNotMatch

#define Error_CIO_SampleModeAndTriggerModeNotMatch (ErrorCodeOffset_CIO - 13)

◆ Error_CIO_SampleModeDoesNotSupportEncoder

#define Error_CIO_SampleModeDoesNotSupportEncoder (ErrorCodeOffset_CIO - 28)

◆ Error_CIO_SampleModeDoesNotSupportFrequencyOrPeriodMeasure

#define Error_CIO_SampleModeDoesNotSupportFrequencyOrPeriodMeasure (ErrorCodeOffset_CIO - 20)

◆ Error_CIO_SampleRateInvalid

#define Error_CIO_SampleRateInvalid (ErrorCodeOffset_CIO - 8)

◆ Error_CIO_SamplesToAcquireInvalid

#define Error_CIO_SamplesToAcquireInvalid (ErrorCodeOffset_CIO - 10)

◆ Error_CIO_SamplesToAcquireNotLessPreTriggerSamples

#define Error_CIO_SamplesToAcquireNotLessPreTriggerSamples (ErrorCodeOffset_CIO - 12)

◆ Error_CIO_SamplesToAcquireOverRange

#define Error_CIO_SamplesToAcquireOverRange (ErrorCodeOffset_CIO - 11)

◆ Error_CIO_SetWorkModeFailed

#define Error_CIO_SetWorkModeFailed (ErrorCodeOffset_CIO - 27)

◆ Error_CIO_TimebaseConfigFailed

#define Error_CIO_TimebaseConfigFailed (ErrorCodeOffset_CIO - 30)

◆ Error_CIO_TriggerDelayInvalid

#define Error_CIO_TriggerDelayInvalid (ErrorCodeOffset_CIO - 16)

◆ Error_CIO_TriggerModeInvalid

#define Error_CIO_TriggerModeInvalid (ErrorCodeOffset_CIO - 18)

◆ Error_CIO_TriggerTypeInvalid

#define Error_CIO_TriggerTypeInvalid (ErrorCodeOffset_CIO - 17)

◆ Error_CIO_UnSupportSampleMode

#define Error_CIO_UnSupportSampleMode (ErrorCodeOffset_CIO - 9)

◆ Error_CLKMuxSelectFailed

#define Error_CLKMuxSelectFailed (ErrorCodeOffset - 14)

◆ Error_CloseDeviceFailed

#define Error_CloseDeviceFailed (ErrorCodeOffset - 2)

◆ Error_DeviceCalibrationCRCVerifyFailed

#define Error_DeviceCalibrationCRCVerifyFailed (ErrorCodeOffset - 28)

◆ Error_DeviceCalibrationDataInvalid

#define Error_DeviceCalibrationDataInvalid (ErrorCodeOffset - 29)

◆ Error_DeviceHandleInvalid

#define Error_DeviceHandleInvalid (ErrorCodeOffset - 9)

◆ Error_DeviceNameInvalid

#define Error_DeviceNameInvalid (ErrorCodeOffset - 8)

◆ Error_DeviceNumberInvalid

#define Error_DeviceNumberInvalid (ErrorCodeOffset - 7)

◆ Error_DevicePropertyInvalid

#define Error_DevicePropertyInvalid (ErrorCodeOffset - 26)

◆ Error_DeviceSlotNumberInvalid

#define Error_DeviceSlotNumberInvalid (ErrorCodeOffset - 6)

◆ Error_DI_BufferOverflow

#define Error_DI_BufferOverflow (ErrorCodeOffset_DI - 31)

◆ Error_DI_BufferPointerIsNull

#define Error_DI_BufferPointerIsNull (ErrorCodeOffset_DI - 29)

◆ Error_DI_BufferSizeInvalid

#define Error_DI_BufferSizeInvalid (ErrorCodeOffset_DI - 23)

◆ Error_DI_DataAddressIsNull

#define Error_DI_DataAddressIsNull (ErrorCodeOffset_DI - 30)

◆ Error_DI_DiagnoseFailed

#define Error_DI_DiagnoseFailed (ErrorCodeOffset_DI - 24)

◆ Error_DI_DigitalTriggerSourceInvalid

#define Error_DI_DigitalTriggerSourceInvalid (ErrorCodeOffset_DI - 22)

◆ Error_DI_ExternalTimeBaseSampleRateInvalid

#define Error_DI_ExternalTimeBaseSampleRateInvalid (ErrorCodeOffset_DI - 34)

◆ Error_DI_LineCountInvalid

#define Error_DI_LineCountInvalid (ErrorCodeOffset_DI - 2)

◆ Error_DI_LineCountOverRang

#define Error_DI_LineCountOverRang (ErrorCodeOffset_DI - 3)

◆ Error_DI_LineIndexOverRange

#define Error_DI_LineIndexOverRange (ErrorCodeOffset_DI - 4)

◆ Error_DI_LineNumberInvalid

#define Error_DI_LineNumberInvalid (ErrorCodeOffset_DI - 1)

◆ Error_DI_NotStart

#define Error_DI_NotStart (ErrorCodeOffset_DI - 27)

◆ Error_DI_PortCountInvalid

#define Error_DI_PortCountInvalid (ErrorCodeOffset_DI - 6)

◆ Error_DI_PortCountOverRang

#define Error_DI_PortCountOverRang (ErrorCodeOffset_DI - 7)

◆ Error_DI_PortIndexOverRange

#define Error_DI_PortIndexOverRange (ErrorCodeOffset_DI - 8)

◆ Error_DI_PortNumberInvalid

#define Error_DI_PortNumberInvalid (ErrorCodeOffset_DI - 5)

◆ Error_DI_PreTriggerSamplesInvalid

#define Error_DI_PreTriggerSamplesInvalid (ErrorCodeOffset_DI - 17)

◆ Error_DI_ReadDataTimeOut

#define Error_DI_ReadDataTimeOut (ErrorCodeOffset_DI - 28)

◆ Error_DI_ReadSinglePortFailed

#define Error_DI_ReadSinglePortFailed (ErrorCodeOffset_DI - 33)

◆ Error_DI_ReTriggerCountInvalid

#define Error_DI_ReTriggerCountInvalid (ErrorCodeOffset_DI - 18)

◆ Error_DI_SampleClockSourceInvalid

#define Error_DI_SampleClockSourceInvalid (ErrorCodeOffset_DI - 10)

◆ Error_DI_SampleModeAndTriggerModeNotMatch

#define Error_DI_SampleModeAndTriggerModeNotMatch (ErrorCodeOffset_DI - 16)

◆ Error_DI_SampleRateInvalid

#define Error_DI_SampleRateInvalid (ErrorCodeOffset_DI - 11)

◆ Error_DI_SamplesToAcquireInvalid

#define Error_DI_SamplesToAcquireInvalid (ErrorCodeOffset_DI - 13)

◆ Error_DI_SamplesToAcquireNotLessPreTriggerSamples

#define Error_DI_SamplesToAcquireNotLessPreTriggerSamples (ErrorCodeOffset_DI - 15)

◆ Error_DI_SamplesToAcquireOverRange

#define Error_DI_SamplesToAcquireOverRange (ErrorCodeOffset_DI - 14)

◆ Error_DI_TimeBaseSourceInvalid

#define Error_DI_TimeBaseSourceInvalid (ErrorCodeOffset_DI - 9)

◆ Error_DI_TimeOut

#define Error_DI_TimeOut (ErrorCodeOffset_DI - 32)

◆ Error_DI_TLastNotAligned

#define Error_DI_TLastNotAligned (ErrorCodeOffset_DI - 25)

◆ Error_DI_TriggerDelayInvalid

#define Error_DI_TriggerDelayInvalid (ErrorCodeOffset_DI - 19)

◆ Error_DI_TriggerModeInvalid

#define Error_DI_TriggerModeInvalid (ErrorCodeOffset_DI - 21)

◆ Error_DI_TriggerStateNotMatch

#define Error_DI_TriggerStateNotMatch (ErrorCodeOffset_DI - 26)

◆ Error_DI_TriggerTypeInvalid

#define Error_DI_TriggerTypeInvalid (ErrorCodeOffset_DI - 20)

◆ Error_DI_UnSupportSampleMode

#define Error_DI_UnSupportSampleMode (ErrorCodeOffset_DI - 12)

◆ Error_DI_WatchDogTimerRunning

#define Error_DI_WatchDogTimerRunning (ErrorCodeOffset_DI - 35)

◆ Error_DIO_LineIsReserved

#define Error_DIO_LineIsReserved (ErrorCodeOffset_PFI - 1)

◆ Error_DO_BufferPointerIsNull

#define Error_DO_BufferPointerIsNull (ErrorCodeOffset_DO - 26)

◆ Error_DO_BufferSizeInvalid

#define Error_DO_BufferSizeInvalid (ErrorCodeOffset_DO - 20)

◆ Error_DO_BufferUnderflow

#define Error_DO_BufferUnderflow (ErrorCodeOffset_DO - 28)

◆ Error_DO_DataAddressIsNull

#define Error_DO_DataAddressIsNull (ErrorCodeOffset_DO - 27)

◆ Error_DO_DiagnoseFailed

#define Error_DO_DiagnoseFailed (ErrorCodeOffset_DO - 21)

◆ Error_DO_DigitalTriggerSourceInvalid

#define Error_DO_DigitalTriggerSourceInvalid (ErrorCodeOffset_DO - 19)

◆ Error_DO_ExternalTimeBaseUpdateRateInvalid

#define Error_DO_ExternalTimeBaseUpdateRateInvalid (ErrorCodeOffset_DO - 32)

◆ Error_DO_FirstWriteMustGreaterOrEqual_1K_Points

#define Error_DO_FirstWriteMustGreaterOrEqual_1K_Points (ErrorCodeOffset_DO - 33)

◆ Error_DO_Inter_TXInitFailed

#define Error_DO_Inter_TXInitFailed (ErrorCodeOffset_DO - 50)

◆ Error_DO_LineCountInvalid

#define Error_DO_LineCountInvalid (ErrorCodeOffset_DO - 2)

◆ Error_DO_LineCountOverRang

#define Error_DO_LineCountOverRang (ErrorCodeOffset_DO - 3)

◆ Error_DO_LineIndexOverRange

#define Error_DO_LineIndexOverRange (ErrorCodeOffset_DO - 4)

◆ Error_DO_LineNumberInvalid

#define Error_DO_LineNumberInvalid (ErrorCodeOffset_DO - 1)

◆ Error_DO_NotStart

#define Error_DO_NotStart (ErrorCodeOffset_DO - 24)

◆ Error_DO_PleaseWritedDataBeforeStart

#define Error_DO_PleaseWritedDataBeforeStart (ErrorCodeOffset_DO - 30)

◆ Error_DO_PortCountInvalid

#define Error_DO_PortCountInvalid (ErrorCodeOffset_DO - 6)

◆ Error_DO_PortCountOverRang

#define Error_DO_PortCountOverRang (ErrorCodeOffset_DO - 7)

◆ Error_DO_PortIndexOverRange

#define Error_DO_PortIndexOverRange (ErrorCodeOffset_DO - 8)

◆ Error_DO_PortNumberInvalid

#define Error_DO_PortNumberInvalid (ErrorCodeOffset_DO - 5)

◆ Error_DO_ReTriggerCountInvalid

#define Error_DO_ReTriggerCountInvalid (ErrorCodeOffset_DO - 15)

◆ Error_DO_SampleClockSourceInvalid

#define Error_DO_SampleClockSourceInvalid (ErrorCodeOffset_DO - 10)

◆ Error_DO_SamplesToUpdateInvalid

#define Error_DO_SamplesToUpdateInvalid (ErrorCodeOffset_DO - 13)

◆ Error_DO_SamplesToUpdateOverRange

#define Error_DO_SamplesToUpdateOverRange (ErrorCodeOffset_DO - 14)

◆ Error_DO_TimeBaseSourceInvalid

#define Error_DO_TimeBaseSourceInvalid (ErrorCodeOffset_DO - 9)

◆ Error_DO_TimeOut

#define Error_DO_TimeOut (ErrorCodeOffset_DO - 29)

◆ Error_DO_TLastNotAligned

#define Error_DO_TLastNotAligned (ErrorCodeOffset_DO - 22)

◆ Error_DO_TriggerDelayInvalid

#define Error_DO_TriggerDelayInvalid (ErrorCodeOffset_DO - 16)

◆ Error_DO_TriggerModeInvalid

#define Error_DO_TriggerModeInvalid (ErrorCodeOffset_DO - 18)

◆ Error_DO_TriggerStateNotMatch

#define Error_DO_TriggerStateNotMatch (ErrorCodeOffset_DO - 23)

◆ Error_DO_TriggerTypeInvalid

#define Error_DO_TriggerTypeInvalid (ErrorCodeOffset_DO - 17)

◆ Error_DO_UnSupportSampleMode

#define Error_DO_UnSupportSampleMode (ErrorCodeOffset_DO - 12)

◆ Error_DO_UpdateRateInvalid

#define Error_DO_UpdateRateInvalid (ErrorCodeOffset_DO - 11)

◆ Error_DO_WriteSinglePortFailed

#define Error_DO_WriteSinglePortFailed (ErrorCodeOffset_DO - 31)

◆ Error_DO_WtiteDataTimeOut

#define Error_DO_WtiteDataTimeOut (ErrorCodeOffset_DO - 25)

◆ Error_FirmwareVersionNotMatch

#define Error_FirmwareVersionNotMatch (ErrorCodeOffset - 27)

◆ Error_GetDeviceAttributeFailed

#define Error_GetDeviceAttributeFailed (ErrorCodeOffset - 19)

◆ Error_GetDeviceCalibrationDataFailed

#define Error_GetDeviceCalibrationDataFailed (ErrorCodeOffset - 21)

◆ Error_InitalDeviceFailed

#define Error_InitalDeviceFailed (ErrorCodeOffset - 4)

◆ Error_InitalEEPROMFailed

#define Error_InitalEEPROMFailed (ErrorCodeOffset - 10)

◆ Error_MallocMemoryFailed

#define Error_MallocMemoryFailed (ErrorCodeOffset - 22)

◆ Error_OpenDeviceFailed

#define Error_OpenDeviceFailed (ErrorCodeOffset - 1)

◆ Error_ParamInvalid

#define Error_ParamInvalid (ErrorCodeOffset - 25)

◆ Error_PFI_FilterPulseWidthOverflow

#define Error_PFI_FilterPulseWidthOverflow (ErrorCodeOffset_PFI - 6)

◆ Error_PFI_LineInvalid

#define Error_PFI_LineInvalid (ErrorCodeOffset_PFI - 2)

◆ Error_PFI_LineIsReserved

#define Error_PFI_LineIsReserved (ErrorCodeOffset_PFI - 3)

◆ Error_PLLCrashed

#define Error_PLLCrashed (ErrorCodeOffset - 17)

◆ Error_PLLLockFailed

#define Error_PLLLockFailed (ErrorCodeOffset - 16)

◆ Error_PLLOutputFreqOutOfRange

#define Error_PLLOutputFreqOutOfRange (ErrorCodeOffset - 18)

◆ Error_PLLSetFailed

#define Error_PLLSetFailed (ErrorCodeOffset - 15)

◆ Error_PXITrgger_LineInvalid

#define Error_PXITrgger_LineInvalid (ErrorCodeOffset_PFI - 4)

◆ Error_PXITrgger_LineIsReserved

#define Error_PXITrgger_LineIsReserved (ErrorCodeOffset_PFI - 5)

◆ Error_ReadEEPROMFailed

#define Error_ReadEEPROMFailed (ErrorCodeOffset - 11)

◆ Error_ReleaseDeviceResourceFailed

#define Error_ReleaseDeviceResourceFailed (ErrorCodeOffset - 24)

◆ Error_ResetDeviceFailed

#define Error_ResetDeviceFailed (ErrorCodeOffset - 3)

◆ Error_SetDeviceAttributeFailed

#define Error_SetDeviceAttributeFailed (ErrorCodeOffset - 20)

◆ Error_TimeBaseSourceInvalid

#define Error_TimeBaseSourceInvalid (ErrorCodeOffset - 13)

◆ Error_UnSupportOperation

#define Error_UnSupportOperation (ErrorCodeOffset - 23)

◆ Error_WatchdogAlreadyStarted

#define Error_WatchdogAlreadyStarted (ErrorCodeOffset_DI - 50)

◆ Error_WatchdogAlreadyStoped

#define Error_WatchdogAlreadyStoped (ErrorCodeOffset_DI - 51)

◆ Error_WriteEEPROMFailed

#define Error_WriteEEPROMFailed (ErrorCodeOffset - 12)

◆ ErrorCodeOffset

#define ErrorCodeOffset (-10000)

◆ ErrorCodeOffset_AI

#define ErrorCodeOffset_AI (-10100)

◆ ErrorCodeOffset_AO

#define ErrorCodeOffset_AO (-10200)

◆ ErrorCodeOffset_CIO

#define ErrorCodeOffset_CIO (-10500)

◆ ErrorCodeOffset_DI

#define ErrorCodeOffset_DI (-10300)

◆ ErrorCodeOffset_DO

#define ErrorCodeOffset_DO (-10400)

◆ ErrorCodeOffset_PFI

#define ErrorCodeOffset_PFI (-10600)

◆ FD_ANALOG_TRIGGER_DUMP_REG_READ_FAILED

#define FD_ANALOG_TRIGGER_DUMP_REG_READ_FAILED ((-5)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))

◆ FD_ANALOG_TRIGGER_ERROR_CODE_OFFSET

#define FD_ANALOG_TRIGGER_ERROR_CODE_OFFSET (-100)

◆ FD_ANALOG_TRIGGER_INPUT_DATA_WIDTH_UNREASONABLE

#define FD_ANALOG_TRIGGER_INPUT_DATA_WIDTH_UNREASONABLE ((-7)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))

◆ FD_ANALOG_TRIGGER_MODESEL_PARAM_OUT_RANGE

#define FD_ANALOG_TRIGGER_MODESEL_PARAM_OUT_RANGE ((-3)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))

◆ FD_ANALOG_TRIGGER_PARALLEL_BYTES_UNSUPPORTED

#define FD_ANALOG_TRIGGER_PARALLEL_BYTES_UNSUPPORTED ((-6)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))

◆ FD_ANALOG_TRIGGER_POINT_IS_NULL

#define FD_ANALOG_TRIGGER_POINT_IS_NULL ((-1)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))

◆ FD_ANALOG_TRIGGER_REG_WRITE_FAILED

#define FD_ANALOG_TRIGGER_REG_WRITE_FAILED ((-4)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))

◆ FD_ANALOG_TRIGGER_THRESHOLD_PARAM_OUT_RANGE

#define FD_ANALOG_TRIGGER_THRESHOLD_PARAM_OUT_RANGE ((-2)+(ANALOG_TRIGGER_ERROR_CODE_OFFSET))

◆ FD_CLK_ENDPOINTS_NOT_SOPPOUTED

#define FD_CLK_ENDPOINTS_NOT_SOPPOUTED -3000-1

◆ FD_COUNTER_DUMP_REG_READ_FAILED

#define FD_COUNTER_DUMP_REG_READ_FAILED ((-3)+(COUNTER_ERROR_CODE_OFFSET))

◆ FD_COUNTER_ERROR_CODE_OFFSET

#define FD_COUNTER_ERROR_CODE_OFFSET (-200)

◆ FD_COUNTER_IP_PARAM_ERROR

#define FD_COUNTER_IP_PARAM_ERROR ((-5)+(COUNTER_ERROR_CODE_OFFSET))

◆ FD_COUNTER_PARAM_OUT_RANGE

#define FD_COUNTER_PARAM_OUT_RANGE ((-4)+(COUNTER_ERROR_CODE_OFFSET))

◆ FD_COUNTER_POINT_IS_NULL

#define FD_COUNTER_POINT_IS_NULL ((-1)+(COUNTER_ERROR_CODE_OFFSET))

◆ FD_COUNTER_REG_WRITE_FAILED

#define FD_COUNTER_REG_WRITE_FAILED ((-2)+(COUNTER_ERROR_CODE_OFFSET))

◆ FD_COUNTER_VERSION_NOT_MATCH

#define FD_COUNTER_VERSION_NOT_MATCH ((-6)+(COUNTER_ERROR_CODE_OFFSET))

◆ FD_PARALLELDI_DUMP_REG_READ_FAILED

#define FD_PARALLELDI_DUMP_REG_READ_FAILED ((-4)+(PARALLELDI_ERROR_CODE_OFFSET))

◆ FD_PARALLELDI_ERROR_CODE_OFFSET

#define FD_PARALLELDI_ERROR_CODE_OFFSET (-400)

◆ FD_PARALLELDI_PARAM_OUT_RANGE

#define FD_PARALLELDI_PARAM_OUT_RANGE ((-2)+(PARALLELDI_ERROR_CODE_OFFSET))

◆ FD_PARALLELDI_POINT_IS_NULL

#define FD_PARALLELDI_POINT_IS_NULL ((-1)+(PARALLELDI_ERROR_CODE_OFFSET))

◆ FD_PARALLELDI_REG_WRITE_FAILED

#define FD_PARALLELDI_REG_WRITE_FAILED ((-3)+(PARALLELDI_ERROR_CODE_OFFSET))

◆ FD_PARALLELDO_DUMP_REG_READ_FAILED

#define FD_PARALLELDO_DUMP_REG_READ_FAILED ((-4)+(PARALLELDO_ERROR_CODE_OFFSET))

◆ FD_PARALLELDO_ERROR_CODE_OFFSET

#define FD_PARALLELDO_ERROR_CODE_OFFSET (-500)

◆ FD_PARALLELDO_PARAM_OUT_RANGE

#define FD_PARALLELDO_PARAM_OUT_RANGE ((-2)+(PARALLELDO_ERROR_CODE_OFFSET))

◆ FD_PARALLELDO_POINT_IS_NULL

#define FD_PARALLELDO_POINT_IS_NULL ((-1)+(PARALLELDO_ERROR_CODE_OFFSET))

◆ FD_PARALLELDO_REG_WRITE_FAILED

#define FD_PARALLELDO_REG_WRITE_FAILED ((-3)+(PARALLELDO_ERROR_CODE_OFFSET))

◆ FD_PFI_DUMP_REG_READ_FAILED

#define FD_PFI_DUMP_REG_READ_FAILED ((-2)+(PFI_ERROR_CODE_OFFSET))

◆ FD_PFI_ERROR_CODE_OFFSET

#define FD_PFI_ERROR_CODE_OFFSET (-800)

◆ FD_PFI_INIT_REG_WRITE_FAILED

#define FD_PFI_INIT_REG_WRITE_FAILED ((-1)+(PFI_ERROR_CODE_OFFSET))

◆ FD_PFI_IP_DISABLEFILTER

#define FD_PFI_IP_DISABLEFILTER ((-5)+(PFI_ERROR_CODE_OFFSET))

◆ FD_PFI_PARAM_OUT_OF_RANG

#define FD_PFI_PARAM_OUT_OF_RANG ((-3)+(PFI_ERROR_CODE_OFFSET))

◆ FD_PFI_POINT_IS_NULL

#define FD_PFI_POINT_IS_NULL ((-4)+(PFI_ERROR_CODE_OFFSET))

◆ FD_PLL_DYNAMIC_BASE_ERROR_CODE

#define FD_PLL_DYNAMIC_BASE_ERROR_CODE -100000

◆ FD_PLL_DYNAMIC_INPUT_OUTRANGE

#define FD_PLL_DYNAMIC_INPUT_OUTRANGE PLL_DYNAMIC_BASE_ERROR_CODE|3

◆ FD_PLL_DYNAMIC_OUT_OUTRANGE

#define FD_PLL_DYNAMIC_OUT_OUTRANGE PLL_DYNAMIC_BASE_ERROR_CODE|5

◆ FD_PLL_DYNAMIC_PFD_OUTRANGE

#define FD_PLL_DYNAMIC_PFD_OUTRANGE PLL_DYNAMIC_BASE_ERROR_CODE|4

◆ FD_PLL_DYNAMIC_UNLOCKED

#define FD_PLL_DYNAMIC_UNLOCKED PLL_DYNAMIC_BASE_ERROR_CODE|1

◆ FD_PLL_DYNAMIC_VCO_OUT_RANFE

#define FD_PLL_DYNAMIC_VCO_OUT_RANFE PLL_DYNAMIC_BASE_ERROR_CODE|2

◆ FD_RoutingMatrix_DUMP_REG_READ_FAILED

#define FD_RoutingMatrix_DUMP_REG_READ_FAILED ((-3)+(RoutingMatrix_ERROR_CODE_OFFSET))

◆ FD_RoutingMatrix_ERROR_CODE_OFFSET

#define FD_RoutingMatrix_ERROR_CODE_OFFSET (-1000)

◆ FD_RoutingMatrix_PARAM_OUT_OF_RANGE

#define FD_RoutingMatrix_PARAM_OUT_OF_RANGE ((-1)+(RoutingMatrix_ERROR_CODE_OFFSET))

◆ FD_RoutingMatrix_POINT_IS_NULL

#define FD_RoutingMatrix_POINT_IS_NULL ((-4)+(RoutingMatrix_ERROR_CODE_OFFSET))

◆ FD_RoutingMatrix_REG_WRITE_FAILED

#define FD_RoutingMatrix_REG_WRITE_FAILED ((-2)+(RoutingMatrix_ERROR_CODE_OFFSET))

◆ FD_RX_DATA_FORMAT_IS_NOT_RIGHT

#define FD_RX_DATA_FORMAT_IS_NOT_RIGHT (RX_ENGINE_ERROR_CODE_BASE - 10)

◆ FD_RX_ENGINE_BYTE_MASK_MUST_BE_UNZERO

#define FD_RX_ENGINE_BYTE_MASK_MUST_BE_UNZERO (RX_ENGINE_ERROR_CODE_BASE - 12)

◆ FD_RX_ENGINE_CHANNEL_CONFIGURATION_ERROR

#define FD_RX_ENGINE_CHANNEL_CONFIGURATION_ERROR (RX_ENGINE_ERROR_CODE_BASE - 2)

◆ FD_RX_ENGINE_COMMAND_STATE_NOT_MATTH

#define FD_RX_ENGINE_COMMAND_STATE_NOT_MATTH (RX_ENGINE_ERROR_CODE_BASE - 9)

◆ FD_RX_ENGINE_DATA_BUFFER_LENGTH_WRONG

#define FD_RX_ENGINE_DATA_BUFFER_LENGTH_WRONG (RX_ENGINE_ERROR_CODE_BASE - 14)

◆ FD_RX_ENGINE_DATA_MOVER_RATE_SLOW_ERROR

#define FD_RX_ENGINE_DATA_MOVER_RATE_SLOW_ERROR (RX_ENGINE_ERROR_CODE_BASE - 18)

◆ FD_RX_ENGINE_DATAMOVER_ERROR

#define FD_RX_ENGINE_DATAMOVER_ERROR (RX_ENGINE_ERROR_CODE_BASE - 4)

◆ FD_RX_ENGINE_ERROR_CODE_BASE

#define FD_RX_ENGINE_ERROR_CODE_BASE (-1100)

◆ FD_RX_ENGINE_FPGA_DATA_MOVER_ERROR

#define FD_RX_ENGINE_FPGA_DATA_MOVER_ERROR (RX_ENGINE_ERROR_CODE_BASE - 16)

◆ FD_RX_ENGINE_FPGA_MEMORY_OVERFLOW

#define FD_RX_ENGINE_FPGA_MEMORY_OVERFLOW (RX_ENGINE_ERROR_CODE_BASE - 1)

◆ FD_RX_ENGINE_HW_TRIIGER_UNENABLED

#define FD_RX_ENGINE_HW_TRIIGER_UNENABLED (RX_ENGINE_ERROR_CODE_BASE - 0)

◆ FD_RX_ENGINE_INPUT_INFORMATION_IS_NULL

#define FD_RX_ENGINE_INPUT_INFORMATION_IS_NULL (RX_ENGINE_ERROR_CODE_BASE - 8)

◆ FD_RX_ENGINE_NO_REFERENCE_TRIGGER

#define FD_RX_ENGINE_NO_REFERENCE_TRIGGER (RX_ENGINE_ERROR_CODE_BASE - 3)

◆ FD_RX_ENGINE_PARAMETER_INVALID

#define FD_RX_ENGINE_PARAMETER_INVALID (RX_ENGINE_ERROR_CODE_BASE - 7)

◆ FD_RX_ENGINE_SAMPLE_BYTES_IS_ZERO

#define FD_RX_ENGINE_SAMPLE_BYTES_IS_ZERO (RX_ENGINE_ERROR_CODE_BASE - 13)

◆ FD_RX_ENGINE_SAMPLE_RATE_IS_TOO_BIG

#define FD_RX_ENGINE_SAMPLE_RATE_IS_TOO_BIG (RX_ENGINE_ERROR_CODE_BASE - 15)

◆ FD_RX_ENGINE_SMPLESIZE_IN_BYTES_ERROR

#define FD_RX_ENGINE_SMPLESIZE_IN_BYTES_ERROR (RX_ENGINE_ERROR_CODE_BASE - 17)

◆ FD_RX_ENGINE_TIME_EXPIRED

#define FD_RX_ENGINE_TIME_EXPIRED (RX_ENGINE_ERROR_CODE_BASE - 6)

◆ FD_RX_ENGINE_USER_DEFINED_START_READ_POINTER_UNRESONABLE

#define FD_RX_ENGINE_USER_DEFINED_START_READ_POINTER_UNRESONABLE (RX_ENGINE_ERROR_CODE_BASE - 19)

◆ FD_RX_FINITE_TRANSFER_IS_NOT_FINISHED

#define FD_RX_FINITE_TRANSFER_IS_NOT_FINISHED (RX_ENGINE_ERROR_CODE_BASE - 5)

◆ FD_TX_ENGINE_COMMAND_STATE_NOT_MATTH

#define FD_TX_ENGINE_COMMAND_STATE_NOT_MATTH (TX_ENGINE_ERROR_CODE_BASE - 9)

◆ FD_TX_ENGINE_DATA_BUFFER_LENGTH_WRONG

#define FD_TX_ENGINE_DATA_BUFFER_LENGTH_WRONG (TX_ENGINE_ERROR_CODE_BASE - 14)

◆ FD_TX_ENGINE_DATA_MOVER_ERROR

#define FD_TX_ENGINE_DATA_MOVER_ERROR (TX_ENGINE_ERROR_CODE_BASE - 5)

◆ FD_TX_ENGINE_DATA_MULTIRECORD_OVERFLOW

#define FD_TX_ENGINE_DATA_MULTIRECORD_OVERFLOW (TX_ENGINE_ERROR_CODE_BASE - 7)

◆ FD_TX_ENGINE_DATA_WRITE_POINTER_UNDERFLOW

#define FD_TX_ENGINE_DATA_WRITE_POINTER_UNDERFLOW (TX_ENGINE_ERROR_CODE_BASE - 6)

◆ FD_TX_ENGINE_ERROR_CODE_BASE

#define FD_TX_ENGINE_ERROR_CODE_BASE -1200

◆ FD_TX_ENGINE_INPUT_INFORMATION_IS_NULL

#define FD_TX_ENGINE_INPUT_INFORMATION_IS_NULL (TX_ENGINE_ERROR_CODE_BASE - 8)

◆ FD_TX_ENGINE_INPUT_SERIAL_PARALLEL_MUTEX

#define FD_TX_ENGINE_INPUT_SERIAL_PARALLEL_MUTEX (TX_ENGINE_ERROR_CODE_BASE - 12)

◆ FD_TX_ENGINE_MEMORYSIZE_UNEQUAL_SENDBYTES

#define FD_TX_ENGINE_MEMORYSIZE_UNEQUAL_SENDBYTES (TX_ENGINE_ERROR_CODE_BASE - 4)

◆ FD_TX_ENGINE_OUTPUT_DATA_WIDTH_READ_ERROR

#define FD_TX_ENGINE_OUTPUT_DATA_WIDTH_READ_ERROR (TX_ENGINE_ERROR_CODE_BASE - 11)

◆ FD_TX_ENGINE_SAMPLE_BYTES_IS_ZERO

#define FD_TX_ENGINE_SAMPLE_BYTES_IS_ZERO (TX_ENGINE_ERROR_CODE_BASE - 13)

◆ FD_TX_ENGINE_SAMPLE_ELEMENTSIZE_IS_ZERO

#define FD_TX_ENGINE_SAMPLE_ELEMENTSIZE_IS_ZERO (TX_ENGINE_ERROR_CODE_BASE - 10)

◆ FD_TX_ENGINE_SAMPLE_RATE_IS_TOO_BIG

#define FD_TX_ENGINE_SAMPLE_RATE_IS_TOO_BIG (TX_ENGINE_ERROR_CODE_BASE - 15)

◆ FD_TX_ENGINE_STROBE_IS_ZERO

#define FD_TX_ENGINE_STROBE_IS_ZERO (TX_ENGINE_ERROR_CODE_BASE - 3)

◆ FD_TX_ENGINE_TIME_EXPIRED

#define FD_TX_ENGINE_TIME_EXPIRED (TX_ENGINE_ERROR_CODE_BASE - 1)

◆ FD_TX_ENGINE_UNDERFLOW

#define FD_TX_ENGINE_UNDERFLOW (TX_ENGINE_ERROR_CODE_BASE - 2)

◆ FD_TX_ENGINE_UPDATE_RATE_NOT_ENOUGH_ERROR

#define FD_TX_ENGINE_UPDATE_RATE_NOT_ENOUGH_ERROR (TX_ENGINE_ERROR_CODE_BASE - 16)

◆ Success

#define Success (0)


5412 C++ Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C ChangeDetectionEventInfo


5412 C++ Programming Manual: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
C
C
ChangeDetectionEventInfo


5412 C++ Programming Manual: C: Directory Reference

  • C:
C: Directory Reference

Directories

         C++


5412 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
 C:
C++
JY5412Core.h
JYDAQError.h


5412 C++ Programming Manual: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all class members with links to the classes they belong to:
  • lineChanged : ChangeDetectionEventInfo
  • lineLevel : ChangeDetectionEventInfo


5412 C++ Programming Manual: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all variables with links to the classes they belong to:
  • lineChanged : ChangeDetectionEventInfo
  • lineLevel : ChangeDetectionEventInfo


5412 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- b -

  • BothEdge : JY5412Core.h


  • Enumerations
  • Enumerator
  • Macros
  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- c -

  • ChangeDetectionEvent : JY5412Core.h
  • CMOS3V3 : JY5412Core.h
  • CMOS5V0 : JY5412Core.h


  • e
  • f
  • j
  • n
  • s
Here is a list of all macros with links to the files they belong to:

- e -

  • Error_A0_NotSupportWriteDataInCurrentMode : JYDAQError.h
  • Error_ActiveDeviceFailed : JYDAQError.h
  • Error_AI_AnalogTriggerNoSupportStartTriggerMode : JYDAQError.h
  • Error_AI_AnalogTriggerSourceInvalid : JYDAQError.h
  • Error_AI_AnalogTriggerThresholdInvalid : JYDAQError.h
  • Error_AI_AnalogTriggerThresholdOverRange : JYDAQError.h
  • Error_AI_BufferOverflow : JYDAQError.h
  • Error_AI_BufferPointerIsNull : JYDAQError.h
  • Error_AI_BufferSizeInvalid : JYDAQError.h
  • Error_AI_ChannelCountInvalid : JYDAQError.h
  • Error_AI_ChannelCountOverRang : JYDAQError.h
  • Error_AI_ChannelIndexOverRange : JYDAQError.h
  • Error_AI_ChannelNumberInvalid : JYDAQError.h
  • Error_AI_ConvertClockSourceInvalid : JYDAQError.h
  • Error_AI_ConvertRateInvalid : JYDAQError.h
  • Error_AI_CoupingInvalid : JYDAQError.h
  • Error_AI_CurrentRangeInvalid : JYDAQError.h
  • Error_AI_DataAddressIsNull : JYDAQError.h
  • Error_AI_DiagnoseFailed : JYDAQError.h
  • Error_AI_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_AI_DSModeSampleRateInvalid : JYDAQError.h
  • Error_AI_ExternalSampleRateOverRange : JYDAQError.h
  • Error_AI_Inter_ADCEnableAdjustFailed : JYDAQError.h
  • Error_AI_Inter_ADCInitFailed : JYDAQError.h
  • Error_AI_Inter_ADCSetAdjustDataFailed : JYDAQError.h
  • Error_AI_Inter_ADCSetChannelFailed : JYDAQError.h
  • Error_AI_Inter_ADCSetSampleRateFailed : JYDAQError.h
  • Error_AI_Inter_ADCStartFailed : JYDAQError.h
  • Error_AI_Inter_ADCStoptFailed : JYDAQError.h
  • Error_AI_Inter_RXInitFailed : JYDAQError.h
  • Error_AI_NotStart : JYDAQError.h
  • Error_AI_PreTriggerSamplesInvalid : JYDAQError.h
  • Error_AI_PreTriggerSamplesMustBeGreaterThanZero : JYDAQError.h
  • Error_AI_ReadDataTimeOut : JYDAQError.h
  • Error_AI_ResistanceRangeInvalid : JYDAQError.h
  • Error_AI_ReTriggerCountInvalid : JYDAQError.h
  • Error_AI_RTDTopologyTypeInvalid : JYDAQError.h
  • Error_AI_SampleClockSourceInvalid : JYDAQError.h
  • Error_AI_SampleModeAndTriggerModeNotMatch : JYDAQError.h
  • Error_AI_SampleRateInvalid : JYDAQError.h
  • Error_AI_SamplesToAcquireInvalid : JYDAQError.h
  • Error_AI_SamplesToAcquireNotLessPreTriggerSamples : JYDAQError.h
  • Error_AI_SamplesToAcquireOverRange : JYDAQError.h
  • Error_AI_TerminalInvalid : JYDAQError.h
  • Error_AI_TimeBaseSourceInvalid : JYDAQError.h
  • Error_AI_TimeOut : JYDAQError.h
  • Error_AI_TLastNotAligned : JYDAQError.h
  • Error_AI_TriggerDelayInvalid : JYDAQError.h
  • Error_AI_TriggerModeInvalid : JYDAQError.h
  • Error_AI_TriggerStateNotMatch : JYDAQError.h
  • Error_AI_TriggerTypeInvalid : JYDAQError.h
  • Error_AI_UnSupportSampleMode : JYDAQError.h
  • Error_AI_VoltageRangInvalid : JYDAQError.h
  • Error_AO_AnalogTriggerSourceInvalid : JYDAQError.h
  • Error_AO_AnalogTriggerThresholdInvalid : JYDAQError.h
  • Error_AO_BufferPointerIsNull : JYDAQError.h
  • Error_AO_BufferSizeInvalid : JYDAQError.h
  • Error_AO_BufferUnderflow : JYDAQError.h
  • Error_AO_ChannelCountInvalid : JYDAQError.h
  • Error_AO_ChannelCountOverRang : JYDAQError.h
  • Error_AO_ChannelIndexOverRange : JYDAQError.h
  • Error_AO_ChannelNumberInvalid : JYDAQError.h
  • Error_AO_CoupingInvalid : JYDAQError.h
  • Error_AO_CurrentRangeInvalid : JYDAQError.h
  • Error_AO_DataAddressIsNull : JYDAQError.h
  • Error_AO_DiagnoseFailed : JYDAQError.h
  • Error_AO_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_AO_FirstWriteMustGreaterOrEqual_1K_Points : JYDAQError.h
  • Error_AO_Inter_DACEnableAdjustFailed : JYDAQError.h
  • Error_AO_Inter_DACInitFailed : JYDAQError.h
  • Error_AO_Inter_DACSetAdjustDataFailed : JYDAQError.h
  • Error_AO_Inter_DACSetChannelFailed : JYDAQError.h
  • Error_AO_Inter_DACSetSampleRateFailed : JYDAQError.h
  • Error_AO_Inter_DACStartFailed : JYDAQError.h
  • Error_AO_Inter_DACStoptFailed : JYDAQError.h
  • Error_AO_Inter_TXClearFailed : JYDAQError.h
  • Error_AO_Inter_TXInitFailed : JYDAQError.h
  • Error_AO_NotStart : JYDAQError.h
  • Error_AO_PleaseWritedDataBeforeStart : JYDAQError.h
  • Error_AO_ReTriggerCountInvalid : JYDAQError.h
  • Error_AO_SampleClockSourceInvalid : JYDAQError.h
  • Error_AO_SamplesToUpdateInvalid : JYDAQError.h
  • Error_AO_SamplesToUpdateOverRange : JYDAQError.h
  • Error_AO_TerminalInvalid : JYDAQError.h
  • Error_AO_TimeBaseSourceInvalid : JYDAQError.h
  • Error_AO_TimeOut : JYDAQError.h
  • Error_AO_TLastNotAligned : JYDAQError.h
  • Error_AO_TriggerDelayInvalid : JYDAQError.h
  • Error_AO_TriggerModeInvalid : JYDAQError.h
  • Error_AO_TriggerStateNotMatch : JYDAQError.h
  • Error_AO_TriggerTypeInvalid : JYDAQError.h
  • Error_AO_UnSupportSampleMode : JYDAQError.h
  • Error_AO_UpdateRateInvalid : JYDAQError.h
  • Error_AO_VoltageRangInvalid : JYDAQError.h
  • Error_AO_WriteSinglePointFailed : JYDAQError.h
  • Error_AO_WtiteDataTimeOut : JYDAQError.h
  • Error_ChangeDetectionAlreadyEnabled : JYDAQError.h
  • Error_ChangeDetectionStopTimeout : JYDAQError.h
  • Error_ChangeDetectionThreadIsRunning : JYDAQError.h
  • Error_CIO__TimeBaseSourceInvalid : JYDAQError.h
  • Error_CIO_BufferOverflow : JYDAQError.h
  • Error_CIO_ChannelInvalid : JYDAQError.h
  • Error_CIO_ChannelIsReserved : JYDAQError.h
  • Error_CIO_ClockTypeDoesNotSupportFrequencyOrPeriodMeasure : JYDAQError.h
  • Error_CIO_ClockTypeDoesNotSupportMeasureType : JYDAQError.h
  • Error_CIO_ConfigCounterTypeFailed : JYDAQError.h
  • Error_CIO_ConfigDirectionFailed : JYDAQError.h
  • Error_CIO_ConfigIdleStateFailed : JYDAQError.h
  • Error_CIO_ConfigInitCountFailed : JYDAQError.h
  • Error_CIO_ConfigInitDelayFailed : JYDAQError.h
  • Error_CIO_ConfigReverseFailed : JYDAQError.h
  • Error_CIO_DelayTooShort : JYDAQError.h
  • Error_CIO_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_CIO_Inter_ReadFrequencyOrPeriodMeasureDataInvalid : JYDAQError.h
  • Error_CIO_Inter_RXInitFailed : JYDAQError.h
  • Error_CIO_Inter_TXInitFailed : JYDAQError.h
  • Error_CIO_NoDataWrittenYet : JYDAQError.h
  • Error_CIO_NotStart : JYDAQError.h
  • Error_CIO_PleaseWritedDataBeforeStart : JYDAQError.h
  • Error_CIO_PreTriggerSamplesInvalid : JYDAQError.h
  • Error_CIO_ReadValueFailed : JYDAQError.h
  • Error_CIO_ReadValueTimeOut : JYDAQError.h
  • Error_CIO_ReTriggerCountInvalid : JYDAQError.h
  • Error_CIO_SampleClockSourceInvalid : JYDAQError.h
  • Error_CIO_SampleModeAndTriggerModeNotMatch : JYDAQError.h
  • Error_CIO_SampleModeDoesNotSupportEncoder : JYDAQError.h
  • Error_CIO_SampleModeDoesNotSupportFrequencyOrPeriodMeasure : JYDAQError.h
  • Error_CIO_SampleRateInvalid : JYDAQError.h
  • Error_CIO_SamplesToAcquireInvalid : JYDAQError.h
  • Error_CIO_SamplesToAcquireNotLessPreTriggerSamples : JYDAQError.h
  • Error_CIO_SamplesToAcquireOverRange : JYDAQError.h
  • Error_CIO_SetWorkModeFailed : JYDAQError.h
  • Error_CIO_TimebaseConfigFailed : JYDAQError.h
  • Error_CIO_TriggerDelayInvalid : JYDAQError.h
  • Error_CIO_TriggerModeInvalid : JYDAQError.h
  • Error_CIO_TriggerTypeInvalid : JYDAQError.h
  • Error_CIO_UnSupportSampleMode : JYDAQError.h
  • Error_CLKMuxSelectFailed : JYDAQError.h
  • Error_CloseDeviceFailed : JYDAQError.h
  • Error_DeviceCalibrationCRCVerifyFailed : JYDAQError.h
  • Error_DeviceCalibrationDataInvalid : JYDAQError.h
  • Error_DeviceHandleInvalid : JYDAQError.h
  • Error_DeviceNameInvalid : JYDAQError.h
  • Error_DeviceNumberInvalid : JYDAQError.h
  • Error_DevicePropertyInvalid : JYDAQError.h
  • Error_DeviceSlotNumberInvalid : JYDAQError.h
  • Error_DI_BufferOverflow : JYDAQError.h
  • Error_DI_BufferPointerIsNull : JYDAQError.h
  • Error_DI_BufferSizeInvalid : JYDAQError.h
  • Error_DI_DataAddressIsNull : JYDAQError.h
  • Error_DI_DiagnoseFailed : JYDAQError.h
  • Error_DI_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_DI_ExternalTimeBaseSampleRateInvalid : JYDAQError.h
  • Error_DI_LineCountInvalid : JYDAQError.h
  • Error_DI_LineCountOverRang : JYDAQError.h
  • Error_DI_LineIndexOverRange : JYDAQError.h
  • Error_DI_LineNumberInvalid : JYDAQError.h
  • Error_DI_NotStart : JYDAQError.h
  • Error_DI_PortCountInvalid : JYDAQError.h
  • Error_DI_PortCountOverRang : JYDAQError.h
  • Error_DI_PortIndexOverRange : JYDAQError.h
  • Error_DI_PortNumberInvalid : JYDAQError.h
  • Error_DI_PreTriggerSamplesInvalid : JYDAQError.h
  • Error_DI_ReadDataTimeOut : JYDAQError.h
  • Error_DI_ReadSinglePortFailed : JYDAQError.h
  • Error_DI_ReTriggerCountInvalid : JYDAQError.h
  • Error_DI_SampleClockSourceInvalid : JYDAQError.h
  • Error_DI_SampleModeAndTriggerModeNotMatch : JYDAQError.h
  • Error_DI_SampleRateInvalid : JYDAQError.h
  • Error_DI_SamplesToAcquireInvalid : JYDAQError.h
  • Error_DI_SamplesToAcquireNotLessPreTriggerSamples : JYDAQError.h
  • Error_DI_SamplesToAcquireOverRange : JYDAQError.h
  • Error_DI_TimeBaseSourceInvalid : JYDAQError.h
  • Error_DI_TimeOut : JYDAQError.h
  • Error_DI_TLastNotAligned : JYDAQError.h
  • Error_DI_TriggerDelayInvalid : JYDAQError.h
  • Error_DI_TriggerModeInvalid : JYDAQError.h
  • Error_DI_TriggerStateNotMatch : JYDAQError.h
  • Error_DI_TriggerTypeInvalid : JYDAQError.h
  • Error_DI_UnSupportSampleMode : JYDAQError.h
  • Error_DI_WatchDogTimerRunning : JYDAQError.h
  • Error_DIO_LineIsReserved : JYDAQError.h
  • Error_DO_BufferPointerIsNull : JYDAQError.h
  • Error_DO_BufferSizeInvalid : JYDAQError.h
  • Error_DO_BufferUnderflow : JYDAQError.h
  • Error_DO_DataAddressIsNull : JYDAQError.h
  • Error_DO_DiagnoseFailed : JYDAQError.h
  • Error_DO_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_DO_ExternalTimeBaseUpdateRateInvalid : JYDAQError.h
  • Error_DO_FirstWriteMustGreaterOrEqual_1K_Points : JYDAQError.h
  • Error_DO_Inter_TXInitFailed : JYDAQError.h
  • Error_DO_LineCountInvalid : JYDAQError.h
  • Error_DO_LineCountOverRang : JYDAQError.h
  • Error_DO_LineIndexOverRange : JYDAQError.h
  • Error_DO_LineNumberInvalid : JYDAQError.h
  • Error_DO_NotStart : JYDAQError.h
  • Error_DO_PleaseWritedDataBeforeStart : JYDAQError.h
  • Error_DO_PortCountInvalid : JYDAQError.h
  • Error_DO_PortCountOverRang : JYDAQError.h
  • Error_DO_PortIndexOverRange : JYDAQError.h
  • Error_DO_PortNumberInvalid : JYDAQError.h
  • Error_DO_ReTriggerCountInvalid : JYDAQError.h
  • Error_DO_SampleClockSourceInvalid : JYDAQError.h
  • Error_DO_SamplesToUpdateInvalid : JYDAQError.h
  • Error_DO_SamplesToUpdateOverRange : JYDAQError.h
  • Error_DO_TimeBaseSourceInvalid : JYDAQError.h
  • Error_DO_TimeOut : JYDAQError.h
  • Error_DO_TLastNotAligned : JYDAQError.h
  • Error_DO_TriggerDelayInvalid : JYDAQError.h
  • Error_DO_TriggerModeInvalid : JYDAQError.h
  • Error_DO_TriggerStateNotMatch : JYDAQError.h
  • Error_DO_TriggerTypeInvalid : JYDAQError.h
  • Error_DO_UnSupportSampleMode : JYDAQError.h
  • Error_DO_UpdateRateInvalid : JYDAQError.h
  • Error_DO_WriteSinglePortFailed : JYDAQError.h
  • Error_DO_WtiteDataTimeOut : JYDAQError.h
  • Error_FirmwareVersionNotMatch : JYDAQError.h
  • Error_GetDeviceAttributeFailed : JYDAQError.h
  • Error_GetDeviceCalibrationDataFailed : JYDAQError.h
  • Error_InitalDeviceFailed : JYDAQError.h
  • Error_InitalEEPROMFailed : JYDAQError.h
  • Error_MallocMemoryFailed : JYDAQError.h
  • Error_OpenDeviceFailed : JYDAQError.h
  • Error_ParamInvalid : JYDAQError.h
  • Error_PFI_FilterPulseWidthOverflow : JYDAQError.h
  • Error_PFI_LineInvalid : JYDAQError.h
  • Error_PFI_LineIsReserved : JYDAQError.h
  • Error_PLLCrashed : JYDAQError.h
  • Error_PLLLockFailed : JYDAQError.h
  • Error_PLLOutputFreqOutOfRange : JYDAQError.h
  • Error_PLLSetFailed : JYDAQError.h
  • Error_PXITrgger_LineInvalid : JYDAQError.h
  • Error_PXITrgger_LineIsReserved : JYDAQError.h
  • Error_ReadEEPROMFailed : JYDAQError.h
  • Error_ReleaseDeviceResourceFailed : JYDAQError.h
  • Error_ResetDeviceFailed : JYDAQError.h
  • Error_SetDeviceAttributeFailed : JYDAQError.h
  • Error_TimeBaseSourceInvalid : JYDAQError.h
  • Error_UnSupportOperation : JYDAQError.h
  • Error_WatchdogAlreadyStarted : JYDAQError.h
  • Error_WatchdogAlreadyStoped : JYDAQError.h
  • Error_WriteEEPROMFailed : JYDAQError.h
  • ErrorCodeOffset : JYDAQError.h
  • ErrorCodeOffset_AI : JYDAQError.h
  • ErrorCodeOffset_AO : JYDAQError.h
  • ErrorCodeOffset_CIO : JYDAQError.h
  • ErrorCodeOffset_DI : JYDAQError.h
  • ErrorCodeOffset_DO : JYDAQError.h
  • ErrorCodeOffset_PFI : JYDAQError.h


  • e
  • f
  • j
  • n
  • s
Here is a list of all macros with links to the files they belong to:

- f -

  • FD_ANALOG_TRIGGER_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_ANALOG_TRIGGER_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_ANALOG_TRIGGER_INPUT_DATA_WIDTH_UNREASONABLE : JYDAQError.h
  • FD_ANALOG_TRIGGER_MODESEL_PARAM_OUT_RANGE : JYDAQError.h
  • FD_ANALOG_TRIGGER_PARALLEL_BYTES_UNSUPPORTED : JYDAQError.h
  • FD_ANALOG_TRIGGER_POINT_IS_NULL : JYDAQError.h
  • FD_ANALOG_TRIGGER_REG_WRITE_FAILED : JYDAQError.h
  • FD_ANALOG_TRIGGER_THRESHOLD_PARAM_OUT_RANGE : JYDAQError.h
  • FD_CLK_ENDPOINTS_NOT_SOPPOUTED : JYDAQError.h
  • FD_COUNTER_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_COUNTER_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_COUNTER_IP_PARAM_ERROR : JYDAQError.h
  • FD_COUNTER_PARAM_OUT_RANGE : JYDAQError.h
  • FD_COUNTER_POINT_IS_NULL : JYDAQError.h
  • FD_COUNTER_REG_WRITE_FAILED : JYDAQError.h
  • FD_COUNTER_VERSION_NOT_MATCH : JYDAQError.h
  • FD_PARALLELDI_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_PARALLELDI_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_PARALLELDI_PARAM_OUT_RANGE : JYDAQError.h
  • FD_PARALLELDI_POINT_IS_NULL : JYDAQError.h
  • FD_PARALLELDI_REG_WRITE_FAILED : JYDAQError.h
  • FD_PARALLELDO_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_PARALLELDO_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_PARALLELDO_PARAM_OUT_RANGE : JYDAQError.h
  • FD_PARALLELDO_POINT_IS_NULL : JYDAQError.h
  • FD_PARALLELDO_REG_WRITE_FAILED : JYDAQError.h
  • FD_PFI_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_PFI_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_PFI_INIT_REG_WRITE_FAILED : JYDAQError.h
  • FD_PFI_IP_DISABLEFILTER : JYDAQError.h
  • FD_PFI_PARAM_OUT_OF_RANG : JYDAQError.h
  • FD_PFI_POINT_IS_NULL : JYDAQError.h
  • FD_PLL_DYNAMIC_BASE_ERROR_CODE : JYDAQError.h
  • FD_PLL_DYNAMIC_INPUT_OUTRANGE : JYDAQError.h
  • FD_PLL_DYNAMIC_OUT_OUTRANGE : JYDAQError.h
  • FD_PLL_DYNAMIC_PFD_OUTRANGE : JYDAQError.h
  • FD_PLL_DYNAMIC_UNLOCKED : JYDAQError.h
  • FD_PLL_DYNAMIC_VCO_OUT_RANFE : JYDAQError.h
  • FD_RoutingMatrix_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_RoutingMatrix_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_RoutingMatrix_PARAM_OUT_OF_RANGE : JYDAQError.h
  • FD_RoutingMatrix_POINT_IS_NULL : JYDAQError.h
  • FD_RoutingMatrix_REG_WRITE_FAILED : JYDAQError.h
  • FD_RX_DATA_FORMAT_IS_NOT_RIGHT : JYDAQError.h
  • FD_RX_ENGINE_BYTE_MASK_MUST_BE_UNZERO : JYDAQError.h
  • FD_RX_ENGINE_CHANNEL_CONFIGURATION_ERROR : JYDAQError.h
  • FD_RX_ENGINE_COMMAND_STATE_NOT_MATTH : JYDAQError.h
  • FD_RX_ENGINE_DATA_BUFFER_LENGTH_WRONG : JYDAQError.h
  • FD_RX_ENGINE_DATA_MOVER_RATE_SLOW_ERROR : JYDAQError.h
  • FD_RX_ENGINE_DATAMOVER_ERROR : JYDAQError.h
  • FD_RX_ENGINE_ERROR_CODE_BASE : JYDAQError.h
  • FD_RX_ENGINE_FPGA_DATA_MOVER_ERROR : JYDAQError.h
  • FD_RX_ENGINE_FPGA_MEMORY_OVERFLOW : JYDAQError.h
  • FD_RX_ENGINE_HW_TRIIGER_UNENABLED : JYDAQError.h
  • FD_RX_ENGINE_INPUT_INFORMATION_IS_NULL : JYDAQError.h
  • FD_RX_ENGINE_NO_REFERENCE_TRIGGER : JYDAQError.h
  • FD_RX_ENGINE_PARAMETER_INVALID : JYDAQError.h
  • FD_RX_ENGINE_SAMPLE_BYTES_IS_ZERO : JYDAQError.h
  • FD_RX_ENGINE_SAMPLE_RATE_IS_TOO_BIG : JYDAQError.h
  • FD_RX_ENGINE_SMPLESIZE_IN_BYTES_ERROR : JYDAQError.h
  • FD_RX_ENGINE_TIME_EXPIRED : JYDAQError.h
  • FD_RX_ENGINE_USER_DEFINED_START_READ_POINTER_UNRESONABLE : JYDAQError.h
  • FD_RX_FINITE_TRANSFER_IS_NOT_FINISHED : JYDAQError.h
  • FD_TX_ENGINE_COMMAND_STATE_NOT_MATTH : JYDAQError.h
  • FD_TX_ENGINE_DATA_BUFFER_LENGTH_WRONG : JYDAQError.h
  • FD_TX_ENGINE_DATA_MOVER_ERROR : JYDAQError.h
  • FD_TX_ENGINE_DATA_MULTIRECORD_OVERFLOW : JYDAQError.h
  • FD_TX_ENGINE_DATA_WRITE_POINTER_UNDERFLOW : JYDAQError.h
  • FD_TX_ENGINE_ERROR_CODE_BASE : JYDAQError.h
  • FD_TX_ENGINE_INPUT_INFORMATION_IS_NULL : JYDAQError.h
  • FD_TX_ENGINE_INPUT_SERIAL_PARALLEL_MUTEX : JYDAQError.h
  • FD_TX_ENGINE_MEMORYSIZE_UNEQUAL_SENDBYTES : JYDAQError.h
  • FD_TX_ENGINE_OUTPUT_DATA_WIDTH_READ_ERROR : JYDAQError.h
  • FD_TX_ENGINE_SAMPLE_BYTES_IS_ZERO : JYDAQError.h
  • FD_TX_ENGINE_SAMPLE_ELEMENTSIZE_IS_ZERO : JYDAQError.h
  • FD_TX_ENGINE_SAMPLE_RATE_IS_TOO_BIG : JYDAQError.h
  • FD_TX_ENGINE_STROBE_IS_ZERO : JYDAQError.h
  • FD_TX_ENGINE_TIME_EXPIRED : JYDAQError.h
  • FD_TX_ENGINE_UNDERFLOW : JYDAQError.h
  • FD_TX_ENGINE_UPDATE_RATE_NOT_ENOUGH_ERROR : JYDAQError.h


  • e
  • f
  • j
  • n
  • s
Here is a list of all macros with links to the files they belong to:

- j -

  • JY5412_NumOfLinesPerPort : JY5412Core.h
  • JY5412_NumOfPort : JY5412Core.h


  • e
  • f
  • j
  • n
  • s
Here is a list of all macros with links to the files they belong to:

- n -

  • NumberOfLines : JY5412Core.h


  • e
  • f
  • j
  • n
  • s
Here is a list of all macros with links to the files they belong to:

- s -

  • Success : JYDAQError.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- e -

  • Error_A0_NotSupportWriteDataInCurrentMode : JYDAQError.h
  • Error_ActiveDeviceFailed : JYDAQError.h
  • Error_AI_AnalogTriggerNoSupportStartTriggerMode : JYDAQError.h
  • Error_AI_AnalogTriggerSourceInvalid : JYDAQError.h
  • Error_AI_AnalogTriggerThresholdInvalid : JYDAQError.h
  • Error_AI_AnalogTriggerThresholdOverRange : JYDAQError.h
  • Error_AI_BufferOverflow : JYDAQError.h
  • Error_AI_BufferPointerIsNull : JYDAQError.h
  • Error_AI_BufferSizeInvalid : JYDAQError.h
  • Error_AI_ChannelCountInvalid : JYDAQError.h
  • Error_AI_ChannelCountOverRang : JYDAQError.h
  • Error_AI_ChannelIndexOverRange : JYDAQError.h
  • Error_AI_ChannelNumberInvalid : JYDAQError.h
  • Error_AI_ConvertClockSourceInvalid : JYDAQError.h
  • Error_AI_ConvertRateInvalid : JYDAQError.h
  • Error_AI_CoupingInvalid : JYDAQError.h
  • Error_AI_CurrentRangeInvalid : JYDAQError.h
  • Error_AI_DataAddressIsNull : JYDAQError.h
  • Error_AI_DiagnoseFailed : JYDAQError.h
  • Error_AI_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_AI_DSModeSampleRateInvalid : JYDAQError.h
  • Error_AI_ExternalSampleRateOverRange : JYDAQError.h
  • Error_AI_Inter_ADCEnableAdjustFailed : JYDAQError.h
  • Error_AI_Inter_ADCInitFailed : JYDAQError.h
  • Error_AI_Inter_ADCSetAdjustDataFailed : JYDAQError.h
  • Error_AI_Inter_ADCSetChannelFailed : JYDAQError.h
  • Error_AI_Inter_ADCSetSampleRateFailed : JYDAQError.h
  • Error_AI_Inter_ADCStartFailed : JYDAQError.h
  • Error_AI_Inter_ADCStoptFailed : JYDAQError.h
  • Error_AI_Inter_RXInitFailed : JYDAQError.h
  • Error_AI_NotStart : JYDAQError.h
  • Error_AI_PreTriggerSamplesInvalid : JYDAQError.h
  • Error_AI_PreTriggerSamplesMustBeGreaterThanZero : JYDAQError.h
  • Error_AI_ReadDataTimeOut : JYDAQError.h
  • Error_AI_ResistanceRangeInvalid : JYDAQError.h
  • Error_AI_ReTriggerCountInvalid : JYDAQError.h
  • Error_AI_RTDTopologyTypeInvalid : JYDAQError.h
  • Error_AI_SampleClockSourceInvalid : JYDAQError.h
  • Error_AI_SampleModeAndTriggerModeNotMatch : JYDAQError.h
  • Error_AI_SampleRateInvalid : JYDAQError.h
  • Error_AI_SamplesToAcquireInvalid : JYDAQError.h
  • Error_AI_SamplesToAcquireNotLessPreTriggerSamples : JYDAQError.h
  • Error_AI_SamplesToAcquireOverRange : JYDAQError.h
  • Error_AI_TerminalInvalid : JYDAQError.h
  • Error_AI_TimeBaseSourceInvalid : JYDAQError.h
  • Error_AI_TimeOut : JYDAQError.h
  • Error_AI_TLastNotAligned : JYDAQError.h
  • Error_AI_TriggerDelayInvalid : JYDAQError.h
  • Error_AI_TriggerModeInvalid : JYDAQError.h
  • Error_AI_TriggerStateNotMatch : JYDAQError.h
  • Error_AI_TriggerTypeInvalid : JYDAQError.h
  • Error_AI_UnSupportSampleMode : JYDAQError.h
  • Error_AI_VoltageRangInvalid : JYDAQError.h
  • Error_AO_AnalogTriggerSourceInvalid : JYDAQError.h
  • Error_AO_AnalogTriggerThresholdInvalid : JYDAQError.h
  • Error_AO_BufferPointerIsNull : JYDAQError.h
  • Error_AO_BufferSizeInvalid : JYDAQError.h
  • Error_AO_BufferUnderflow : JYDAQError.h
  • Error_AO_ChannelCountInvalid : JYDAQError.h
  • Error_AO_ChannelCountOverRang : JYDAQError.h
  • Error_AO_ChannelIndexOverRange : JYDAQError.h
  • Error_AO_ChannelNumberInvalid : JYDAQError.h
  • Error_AO_CoupingInvalid : JYDAQError.h
  • Error_AO_CurrentRangeInvalid : JYDAQError.h
  • Error_AO_DataAddressIsNull : JYDAQError.h
  • Error_AO_DiagnoseFailed : JYDAQError.h
  • Error_AO_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_AO_FirstWriteMustGreaterOrEqual_1K_Points : JYDAQError.h
  • Error_AO_Inter_DACEnableAdjustFailed : JYDAQError.h
  • Error_AO_Inter_DACInitFailed : JYDAQError.h
  • Error_AO_Inter_DACSetAdjustDataFailed : JYDAQError.h
  • Error_AO_Inter_DACSetChannelFailed : JYDAQError.h
  • Error_AO_Inter_DACSetSampleRateFailed : JYDAQError.h
  • Error_AO_Inter_DACStartFailed : JYDAQError.h
  • Error_AO_Inter_DACStoptFailed : JYDAQError.h
  • Error_AO_Inter_TXClearFailed : JYDAQError.h
  • Error_AO_Inter_TXInitFailed : JYDAQError.h
  • Error_AO_NotStart : JYDAQError.h
  • Error_AO_PleaseWritedDataBeforeStart : JYDAQError.h
  • Error_AO_ReTriggerCountInvalid : JYDAQError.h
  • Error_AO_SampleClockSourceInvalid : JYDAQError.h
  • Error_AO_SamplesToUpdateInvalid : JYDAQError.h
  • Error_AO_SamplesToUpdateOverRange : JYDAQError.h
  • Error_AO_TerminalInvalid : JYDAQError.h
  • Error_AO_TimeBaseSourceInvalid : JYDAQError.h
  • Error_AO_TimeOut : JYDAQError.h
  • Error_AO_TLastNotAligned : JYDAQError.h
  • Error_AO_TriggerDelayInvalid : JYDAQError.h
  • Error_AO_TriggerModeInvalid : JYDAQError.h
  • Error_AO_TriggerStateNotMatch : JYDAQError.h
  • Error_AO_TriggerTypeInvalid : JYDAQError.h
  • Error_AO_UnSupportSampleMode : JYDAQError.h
  • Error_AO_UpdateRateInvalid : JYDAQError.h
  • Error_AO_VoltageRangInvalid : JYDAQError.h
  • Error_AO_WriteSinglePointFailed : JYDAQError.h
  • Error_AO_WtiteDataTimeOut : JYDAQError.h
  • Error_ChangeDetectionAlreadyEnabled : JYDAQError.h
  • Error_ChangeDetectionStopTimeout : JYDAQError.h
  • Error_ChangeDetectionThreadIsRunning : JYDAQError.h
  • Error_CIO__TimeBaseSourceInvalid : JYDAQError.h
  • Error_CIO_BufferOverflow : JYDAQError.h
  • Error_CIO_ChannelInvalid : JYDAQError.h
  • Error_CIO_ChannelIsReserved : JYDAQError.h
  • Error_CIO_ClockTypeDoesNotSupportFrequencyOrPeriodMeasure : JYDAQError.h
  • Error_CIO_ClockTypeDoesNotSupportMeasureType : JYDAQError.h
  • Error_CIO_ConfigCounterTypeFailed : JYDAQError.h
  • Error_CIO_ConfigDirectionFailed : JYDAQError.h
  • Error_CIO_ConfigIdleStateFailed : JYDAQError.h
  • Error_CIO_ConfigInitCountFailed : JYDAQError.h
  • Error_CIO_ConfigInitDelayFailed : JYDAQError.h
  • Error_CIO_ConfigReverseFailed : JYDAQError.h
  • Error_CIO_DelayTooShort : JYDAQError.h
  • Error_CIO_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_CIO_Inter_ReadFrequencyOrPeriodMeasureDataInvalid : JYDAQError.h
  • Error_CIO_Inter_RXInitFailed : JYDAQError.h
  • Error_CIO_Inter_TXInitFailed : JYDAQError.h
  • Error_CIO_NoDataWrittenYet : JYDAQError.h
  • Error_CIO_NotStart : JYDAQError.h
  • Error_CIO_PleaseWritedDataBeforeStart : JYDAQError.h
  • Error_CIO_PreTriggerSamplesInvalid : JYDAQError.h
  • Error_CIO_ReadValueFailed : JYDAQError.h
  • Error_CIO_ReadValueTimeOut : JYDAQError.h
  • Error_CIO_ReTriggerCountInvalid : JYDAQError.h
  • Error_CIO_SampleClockSourceInvalid : JYDAQError.h
  • Error_CIO_SampleModeAndTriggerModeNotMatch : JYDAQError.h
  • Error_CIO_SampleModeDoesNotSupportEncoder : JYDAQError.h
  • Error_CIO_SampleModeDoesNotSupportFrequencyOrPeriodMeasure : JYDAQError.h
  • Error_CIO_SampleRateInvalid : JYDAQError.h
  • Error_CIO_SamplesToAcquireInvalid : JYDAQError.h
  • Error_CIO_SamplesToAcquireNotLessPreTriggerSamples : JYDAQError.h
  • Error_CIO_SamplesToAcquireOverRange : JYDAQError.h
  • Error_CIO_SetWorkModeFailed : JYDAQError.h
  • Error_CIO_TimebaseConfigFailed : JYDAQError.h
  • Error_CIO_TriggerDelayInvalid : JYDAQError.h
  • Error_CIO_TriggerModeInvalid : JYDAQError.h
  • Error_CIO_TriggerTypeInvalid : JYDAQError.h
  • Error_CIO_UnSupportSampleMode : JYDAQError.h
  • Error_CLKMuxSelectFailed : JYDAQError.h
  • Error_CloseDeviceFailed : JYDAQError.h
  • Error_DeviceCalibrationCRCVerifyFailed : JYDAQError.h
  • Error_DeviceCalibrationDataInvalid : JYDAQError.h
  • Error_DeviceHandleInvalid : JYDAQError.h
  • Error_DeviceNameInvalid : JYDAQError.h
  • Error_DeviceNumberInvalid : JYDAQError.h
  • Error_DevicePropertyInvalid : JYDAQError.h
  • Error_DeviceSlotNumberInvalid : JYDAQError.h
  • Error_DI_BufferOverflow : JYDAQError.h
  • Error_DI_BufferPointerIsNull : JYDAQError.h
  • Error_DI_BufferSizeInvalid : JYDAQError.h
  • Error_DI_DataAddressIsNull : JYDAQError.h
  • Error_DI_DiagnoseFailed : JYDAQError.h
  • Error_DI_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_DI_ExternalTimeBaseSampleRateInvalid : JYDAQError.h
  • Error_DI_LineCountInvalid : JYDAQError.h
  • Error_DI_LineCountOverRang : JYDAQError.h
  • Error_DI_LineIndexOverRange : JYDAQError.h
  • Error_DI_LineNumberInvalid : JYDAQError.h
  • Error_DI_NotStart : JYDAQError.h
  • Error_DI_PortCountInvalid : JYDAQError.h
  • Error_DI_PortCountOverRang : JYDAQError.h
  • Error_DI_PortIndexOverRange : JYDAQError.h
  • Error_DI_PortNumberInvalid : JYDAQError.h
  • Error_DI_PreTriggerSamplesInvalid : JYDAQError.h
  • Error_DI_ReadDataTimeOut : JYDAQError.h
  • Error_DI_ReadSinglePortFailed : JYDAQError.h
  • Error_DI_ReTriggerCountInvalid : JYDAQError.h
  • Error_DI_SampleClockSourceInvalid : JYDAQError.h
  • Error_DI_SampleModeAndTriggerModeNotMatch : JYDAQError.h
  • Error_DI_SampleRateInvalid : JYDAQError.h
  • Error_DI_SamplesToAcquireInvalid : JYDAQError.h
  • Error_DI_SamplesToAcquireNotLessPreTriggerSamples : JYDAQError.h
  • Error_DI_SamplesToAcquireOverRange : JYDAQError.h
  • Error_DI_TimeBaseSourceInvalid : JYDAQError.h
  • Error_DI_TimeOut : JYDAQError.h
  • Error_DI_TLastNotAligned : JYDAQError.h
  • Error_DI_TriggerDelayInvalid : JYDAQError.h
  • Error_DI_TriggerModeInvalid : JYDAQError.h
  • Error_DI_TriggerStateNotMatch : JYDAQError.h
  • Error_DI_TriggerTypeInvalid : JYDAQError.h
  • Error_DI_UnSupportSampleMode : JYDAQError.h
  • Error_DI_WatchDogTimerRunning : JYDAQError.h
  • Error_DIO_LineIsReserved : JYDAQError.h
  • Error_DO_BufferPointerIsNull : JYDAQError.h
  • Error_DO_BufferSizeInvalid : JYDAQError.h
  • Error_DO_BufferUnderflow : JYDAQError.h
  • Error_DO_DataAddressIsNull : JYDAQError.h
  • Error_DO_DiagnoseFailed : JYDAQError.h
  • Error_DO_DigitalTriggerSourceInvalid : JYDAQError.h
  • Error_DO_ExternalTimeBaseUpdateRateInvalid : JYDAQError.h
  • Error_DO_FirstWriteMustGreaterOrEqual_1K_Points : JYDAQError.h
  • Error_DO_Inter_TXInitFailed : JYDAQError.h
  • Error_DO_LineCountInvalid : JYDAQError.h
  • Error_DO_LineCountOverRang : JYDAQError.h
  • Error_DO_LineIndexOverRange : JYDAQError.h
  • Error_DO_LineNumberInvalid : JYDAQError.h
  • Error_DO_NotStart : JYDAQError.h
  • Error_DO_PleaseWritedDataBeforeStart : JYDAQError.h
  • Error_DO_PortCountInvalid : JYDAQError.h
  • Error_DO_PortCountOverRang : JYDAQError.h
  • Error_DO_PortIndexOverRange : JYDAQError.h
  • Error_DO_PortNumberInvalid : JYDAQError.h
  • Error_DO_ReTriggerCountInvalid : JYDAQError.h
  • Error_DO_SampleClockSourceInvalid : JYDAQError.h
  • Error_DO_SamplesToUpdateInvalid : JYDAQError.h
  • Error_DO_SamplesToUpdateOverRange : JYDAQError.h
  • Error_DO_TimeBaseSourceInvalid : JYDAQError.h
  • Error_DO_TimeOut : JYDAQError.h
  • Error_DO_TLastNotAligned : JYDAQError.h
  • Error_DO_TriggerDelayInvalid : JYDAQError.h
  • Error_DO_TriggerModeInvalid : JYDAQError.h
  • Error_DO_TriggerStateNotMatch : JYDAQError.h
  • Error_DO_TriggerTypeInvalid : JYDAQError.h
  • Error_DO_UnSupportSampleMode : JYDAQError.h
  • Error_DO_UpdateRateInvalid : JYDAQError.h
  • Error_DO_WriteSinglePortFailed : JYDAQError.h
  • Error_DO_WtiteDataTimeOut : JYDAQError.h
  • Error_FirmwareVersionNotMatch : JYDAQError.h
  • Error_GetDeviceAttributeFailed : JYDAQError.h
  • Error_GetDeviceCalibrationDataFailed : JYDAQError.h
  • Error_InitalDeviceFailed : JYDAQError.h
  • Error_InitalEEPROMFailed : JYDAQError.h
  • Error_MallocMemoryFailed : JYDAQError.h
  • Error_OpenDeviceFailed : JYDAQError.h
  • Error_ParamInvalid : JYDAQError.h
  • Error_PFI_FilterPulseWidthOverflow : JYDAQError.h
  • Error_PFI_LineInvalid : JYDAQError.h
  • Error_PFI_LineIsReserved : JYDAQError.h
  • Error_PLLCrashed : JYDAQError.h
  • Error_PLLLockFailed : JYDAQError.h
  • Error_PLLOutputFreqOutOfRange : JYDAQError.h
  • Error_PLLSetFailed : JYDAQError.h
  • Error_PXITrgger_LineInvalid : JYDAQError.h
  • Error_PXITrgger_LineIsReserved : JYDAQError.h
  • Error_ReadEEPROMFailed : JYDAQError.h
  • Error_ReleaseDeviceResourceFailed : JYDAQError.h
  • Error_ResetDeviceFailed : JYDAQError.h
  • Error_SetDeviceAttributeFailed : JYDAQError.h
  • Error_TimeBaseSourceInvalid : JYDAQError.h
  • Error_UnSupportOperation : JYDAQError.h
  • Error_WatchdogAlreadyStarted : JYDAQError.h
  • Error_WatchdogAlreadyStoped : JYDAQError.h
  • Error_WriteEEPROMFailed : JYDAQError.h
  • ErrorCodeOffset : JYDAQError.h
  • ErrorCodeOffset_AI : JYDAQError.h
  • ErrorCodeOffset_AO : JYDAQError.h
  • ErrorCodeOffset_CIO : JYDAQError.h
  • ErrorCodeOffset_DI : JYDAQError.h
  • ErrorCodeOffset_DO : JYDAQError.h
  • ErrorCodeOffset_PFI : JYDAQError.h
  • EventCounter : JY5412Core.h


Here is a list of all enums with links to the files they belong to:
  • JY5412_ChangeDetectionMode : JY5412Core.h
  • JY5412_ChangeDetectionSource : JY5412Core.h
  • JY5412_DI_Terminal : JY5412Core.h
  • JY5412_DIO_Direction : JY5412Core.h
  • JY5412_DO_ExpirationState : JY5412Core.h
  • JY5412_DO_Terminal : JY5412Core.h
  • JY5412_Event : JY5412Core.h
  • JY5412_LogicLevel : JY5412Core.h


Here is a list of all enum values with links to the files they belong to:
  • BothEdge : JY5412Core.h
  • ChangeDetectionEvent : JY5412Core.h
  • CMOS3V3 : JY5412Core.h
  • CMOS5V0 : JY5412Core.h
  • EventCounter : JY5412Core.h
  • FallingEdge : JY5412Core.h
  • Floating : JY5412Core.h
  • High : JY5412Core.h
  • Input : JY5412Core.h
  • LinesCOS : JY5412Core.h
  • LineXOrnLineY : JY5412Core.h
  • Low : JY5412Core.h
  • NoChange : JY5412Core.h
  • OpenDrain : JY5412Core.h
  • Output : JY5412Core.h
  • PullDown : JY5412Core.h
  • PullUp : JY5412Core.h
  • PushPull : JY5412Core.h
  • RisingEdge : JY5412Core.h
  • Timer : JY5412Core.h
  • Tristate : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- f -

  • FallingEdge : JY5412Core.h
  • FD_ANALOG_TRIGGER_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_ANALOG_TRIGGER_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_ANALOG_TRIGGER_INPUT_DATA_WIDTH_UNREASONABLE : JYDAQError.h
  • FD_ANALOG_TRIGGER_MODESEL_PARAM_OUT_RANGE : JYDAQError.h
  • FD_ANALOG_TRIGGER_PARALLEL_BYTES_UNSUPPORTED : JYDAQError.h
  • FD_ANALOG_TRIGGER_POINT_IS_NULL : JYDAQError.h
  • FD_ANALOG_TRIGGER_REG_WRITE_FAILED : JYDAQError.h
  • FD_ANALOG_TRIGGER_THRESHOLD_PARAM_OUT_RANGE : JYDAQError.h
  • FD_CLK_ENDPOINTS_NOT_SOPPOUTED : JYDAQError.h
  • FD_COUNTER_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_COUNTER_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_COUNTER_IP_PARAM_ERROR : JYDAQError.h
  • FD_COUNTER_PARAM_OUT_RANGE : JYDAQError.h
  • FD_COUNTER_POINT_IS_NULL : JYDAQError.h
  • FD_COUNTER_REG_WRITE_FAILED : JYDAQError.h
  • FD_COUNTER_VERSION_NOT_MATCH : JYDAQError.h
  • FD_PARALLELDI_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_PARALLELDI_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_PARALLELDI_PARAM_OUT_RANGE : JYDAQError.h
  • FD_PARALLELDI_POINT_IS_NULL : JYDAQError.h
  • FD_PARALLELDI_REG_WRITE_FAILED : JYDAQError.h
  • FD_PARALLELDO_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_PARALLELDO_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_PARALLELDO_PARAM_OUT_RANGE : JYDAQError.h
  • FD_PARALLELDO_POINT_IS_NULL : JYDAQError.h
  • FD_PARALLELDO_REG_WRITE_FAILED : JYDAQError.h
  • FD_PFI_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_PFI_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_PFI_INIT_REG_WRITE_FAILED : JYDAQError.h
  • FD_PFI_IP_DISABLEFILTER : JYDAQError.h
  • FD_PFI_PARAM_OUT_OF_RANG : JYDAQError.h
  • FD_PFI_POINT_IS_NULL : JYDAQError.h
  • FD_PLL_DYNAMIC_BASE_ERROR_CODE : JYDAQError.h
  • FD_PLL_DYNAMIC_INPUT_OUTRANGE : JYDAQError.h
  • FD_PLL_DYNAMIC_OUT_OUTRANGE : JYDAQError.h
  • FD_PLL_DYNAMIC_PFD_OUTRANGE : JYDAQError.h
  • FD_PLL_DYNAMIC_UNLOCKED : JYDAQError.h
  • FD_PLL_DYNAMIC_VCO_OUT_RANFE : JYDAQError.h
  • FD_RoutingMatrix_DUMP_REG_READ_FAILED : JYDAQError.h
  • FD_RoutingMatrix_ERROR_CODE_OFFSET : JYDAQError.h
  • FD_RoutingMatrix_PARAM_OUT_OF_RANGE : JYDAQError.h
  • FD_RoutingMatrix_POINT_IS_NULL : JYDAQError.h
  • FD_RoutingMatrix_REG_WRITE_FAILED : JYDAQError.h
  • FD_RX_DATA_FORMAT_IS_NOT_RIGHT : JYDAQError.h
  • FD_RX_ENGINE_BYTE_MASK_MUST_BE_UNZERO : JYDAQError.h
  • FD_RX_ENGINE_CHANNEL_CONFIGURATION_ERROR : JYDAQError.h
  • FD_RX_ENGINE_COMMAND_STATE_NOT_MATTH : JYDAQError.h
  • FD_RX_ENGINE_DATA_BUFFER_LENGTH_WRONG : JYDAQError.h
  • FD_RX_ENGINE_DATA_MOVER_RATE_SLOW_ERROR : JYDAQError.h
  • FD_RX_ENGINE_DATAMOVER_ERROR : JYDAQError.h
  • FD_RX_ENGINE_ERROR_CODE_BASE : JYDAQError.h
  • FD_RX_ENGINE_FPGA_DATA_MOVER_ERROR : JYDAQError.h
  • FD_RX_ENGINE_FPGA_MEMORY_OVERFLOW : JYDAQError.h
  • FD_RX_ENGINE_HW_TRIIGER_UNENABLED : JYDAQError.h
  • FD_RX_ENGINE_INPUT_INFORMATION_IS_NULL : JYDAQError.h
  • FD_RX_ENGINE_NO_REFERENCE_TRIGGER : JYDAQError.h
  • FD_RX_ENGINE_PARAMETER_INVALID : JYDAQError.h
  • FD_RX_ENGINE_SAMPLE_BYTES_IS_ZERO : JYDAQError.h
  • FD_RX_ENGINE_SAMPLE_RATE_IS_TOO_BIG : JYDAQError.h
  • FD_RX_ENGINE_SMPLESIZE_IN_BYTES_ERROR : JYDAQError.h
  • FD_RX_ENGINE_TIME_EXPIRED : JYDAQError.h
  • FD_RX_ENGINE_USER_DEFINED_START_READ_POINTER_UNRESONABLE : JYDAQError.h
  • FD_RX_FINITE_TRANSFER_IS_NOT_FINISHED : JYDAQError.h
  • FD_TX_ENGINE_COMMAND_STATE_NOT_MATTH : JYDAQError.h
  • FD_TX_ENGINE_DATA_BUFFER_LENGTH_WRONG : JYDAQError.h
  • FD_TX_ENGINE_DATA_MOVER_ERROR : JYDAQError.h
  • FD_TX_ENGINE_DATA_MULTIRECORD_OVERFLOW : JYDAQError.h
  • FD_TX_ENGINE_DATA_WRITE_POINTER_UNDERFLOW : JYDAQError.h
  • FD_TX_ENGINE_ERROR_CODE_BASE : JYDAQError.h
  • FD_TX_ENGINE_INPUT_INFORMATION_IS_NULL : JYDAQError.h
  • FD_TX_ENGINE_INPUT_SERIAL_PARALLEL_MUTEX : JYDAQError.h
  • FD_TX_ENGINE_MEMORYSIZE_UNEQUAL_SENDBYTES : JYDAQError.h
  • FD_TX_ENGINE_OUTPUT_DATA_WIDTH_READ_ERROR : JYDAQError.h
  • FD_TX_ENGINE_SAMPLE_BYTES_IS_ZERO : JYDAQError.h
  • FD_TX_ENGINE_SAMPLE_ELEMENTSIZE_IS_ZERO : JYDAQError.h
  • FD_TX_ENGINE_SAMPLE_RATE_IS_TOO_BIG : JYDAQError.h
  • FD_TX_ENGINE_STROBE_IS_ZERO : JYDAQError.h
  • FD_TX_ENGINE_TIME_EXPIRED : JYDAQError.h
  • FD_TX_ENGINE_UNDERFLOW : JYDAQError.h
  • FD_TX_ENGINE_UPDATE_RATE_NOT_ENOUGH_ERROR : JYDAQError.h
  • Floating : JY5412Core.h


  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY5412_ChangeDetection_Config() : JY5412Core.h
  • JY5412_ChangeDetection_Enable() : JY5412Core.h
  • JY5412_ChangeDetection_RegisterEventHandler() : JY5412Core.h
  • JY5412_ChangeDetection_SendEvent() : JY5412Core.h
  • JY5412_Close() : JY5412Core.h
  • JY5412_CommitDIOConfiguration() : JY5412Core.h
  • JY5412_CommitPowerUpStates() : JY5412Core.h
  • JY5412_ConfigInput() : JY5412Core.h
  • JY5412_ConfigOutput() : JY5412Core.h
  • JY5412_DebounceFilter_Enable() : JY5412Core.h
  • JY5412_DebounceFilter_SetMinPulseWidth() : JY5412Core.h
  • JY5412_GetInputPowerUpStates() : JY5412Core.h
  • JY5412_GetLogicLevelPowerUpStates() : JY5412Core.h
  • JY5412_GetOutputPowerUpStates() : JY5412Core.h
  • JY5412_GetPowerUpStates() : JY5412Core.h
  • JY5412_Open() : JY5412Core.h
  • JY5412_OpenByName() : JY5412Core.h
  • JY5412_ReadDigitalLines() : JY5412Core.h
  • JY5412_SetDeviceStatusLed() : JY5412Core.h
  • JY5412_SetInputPowerUpStates() : JY5412Core.h
  • JY5412_SetLogicLevel() : JY5412Core.h
  • JY5412_SetLogicLevelPowerUpStates() : JY5412Core.h
  • JY5412_SetOutputPowerUpStates() : JY5412Core.h
  • JY5412_Watchdog_CheckIfExpired() : JY5412Core.h
  • JY5412_Watchdog_ClearExpiration() : JY5412Core.h
  • JY5412_Watchdog_Config() : JY5412Core.h
  • JY5412_Watchdog_GetExpirationState() : JY5412Core.h
  • JY5412_Watchdog_GetTimeout() : JY5412Core.h
  • JY5412_Watchdog_ResetTimer() : JY5412Core.h
  • JY5412_Watchdog_SetExpirationState() : JY5412Core.h
  • JY5412_Watchdog_SetTimeout() : JY5412Core.h
  • JY5412_Watchdog_Start() : JY5412Core.h
  • JY5412_Watchdog_Stop() : JY5412Core.h
  • JY5412_WriteDigitalLines() : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- h -

  • High : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- i -

  • Input : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- j -

  • JY5412_CallbackFunc : JY5412Core.h
  • JY5412_ChangeDetection_Config() : JY5412Core.h
  • JY5412_ChangeDetection_Enable() : JY5412Core.h
  • JY5412_ChangeDetection_RegisterEventHandler() : JY5412Core.h
  • JY5412_ChangeDetection_SendEvent() : JY5412Core.h
  • JY5412_ChangeDetectionMode : JY5412Core.h
  • JY5412_ChangeDetectionSource : JY5412Core.h
  • JY5412_Close() : JY5412Core.h
  • JY5412_CommitDIOConfiguration() : JY5412Core.h
  • JY5412_CommitPowerUpStates() : JY5412Core.h
  • JY5412_ConfigInput() : JY5412Core.h
  • JY5412_ConfigOutput() : JY5412Core.h
  • JY5412_DebounceFilter_Enable() : JY5412Core.h
  • JY5412_DebounceFilter_SetMinPulseWidth() : JY5412Core.h
  • JY5412_DeviceHandle : JY5412Core.h
  • JY5412_DI_Terminal : JY5412Core.h
  • JY5412_DIO_Direction : JY5412Core.h
  • JY5412_DO_ExpirationState : JY5412Core.h
  • JY5412_DO_Terminal : JY5412Core.h
  • JY5412_Event : JY5412Core.h
  • JY5412_GetInputPowerUpStates() : JY5412Core.h
  • JY5412_GetLogicLevelPowerUpStates() : JY5412Core.h
  • JY5412_GetOutputPowerUpStates() : JY5412Core.h
  • JY5412_GetPowerUpStates() : JY5412Core.h
  • JY5412_LogicLevel : JY5412Core.h
  • JY5412_NumOfLinesPerPort : JY5412Core.h
  • JY5412_NumOfPort : JY5412Core.h
  • JY5412_Open() : JY5412Core.h
  • JY5412_OpenByName() : JY5412Core.h
  • JY5412_ReadDigitalLines() : JY5412Core.h
  • JY5412_SetDeviceStatusLed() : JY5412Core.h
  • JY5412_SetInputPowerUpStates() : JY5412Core.h
  • JY5412_SetLogicLevel() : JY5412Core.h
  • JY5412_SetLogicLevelPowerUpStates() : JY5412Core.h
  • JY5412_SetOutputPowerUpStates() : JY5412Core.h
  • JY5412_TaskHandle : JY5412Core.h
  • JY5412_Watchdog_CheckIfExpired() : JY5412Core.h
  • JY5412_Watchdog_ClearExpiration() : JY5412Core.h
  • JY5412_Watchdog_Config() : JY5412Core.h
  • JY5412_Watchdog_GetExpirationState() : JY5412Core.h
  • JY5412_Watchdog_GetTimeout() : JY5412Core.h
  • JY5412_Watchdog_ResetTimer() : JY5412Core.h
  • JY5412_Watchdog_SetExpirationState() : JY5412Core.h
  • JY5412_Watchdog_SetTimeout() : JY5412Core.h
  • JY5412_Watchdog_Start() : JY5412Core.h
  • JY5412_Watchdog_Stop() : JY5412Core.h
  • JY5412_WriteDigitalLines() : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- l -

  • LinesCOS : JY5412Core.h
  • LineXOrnLineY : JY5412Core.h
  • Low : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- n -

  • NoChange : JY5412Core.h
  • NumberOfLines : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- o -

  • OpenDrain : JY5412Core.h
  • Output : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- p -

  • PullDown : JY5412Core.h
  • PullUp : JY5412Core.h
  • PushPull : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- r -

  • RisingEdge : JY5412Core.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- s -

  • Success : JYDAQError.h


  • b
  • c
  • e
  • f
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all file members with links to the files they belong to:

- t -

  • Timer : JY5412Core.h
  • Tristate : JY5412Core.h


Here is a list of all typedefs with links to the files they belong to:
  • JY5412_CallbackFunc : JY5412Core.h
  • JY5412_DeviceHandle : JY5412Core.h
  • JY5412_TaskHandle : JY5412Core.h


5412 C++ Programming Manual: Main Page

5412 C++ Programming Manual Documentation


5412 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
ChangeDetectionEventInfo Member List

This is the complete list of members for ChangeDetectionEventInfo, including all inherited members.

lineChanged | ChangeDetectionEventInfo
lineLevel | ChangeDetectionEventInfo